Jump to content

Bug reports for version 9


Helen Brown
 Share

Recommended Posts

Yes, probably that workspace is corrupted as well.

That didn't work either. Now even when Startup->Default Search Window is set and I try to open an workspace (which was newly created after dumping the corrupted startup session), the program crashes. It will open again, but now it seems the problem is not with startup but with workspace feature. I'm baffled.

Link to comment
Share on other sites

  • Replies 62
  • Created
  • Last Reply

Top Posters In This Topic

  • Joel Brown

    9

  • Helen Brown

    8

  • Tom Castle

    8

  • TjpwX

    7

Top Posters In This Topic

Posted Images

Yes, probably that workspace is corrupted as well.

 

I am watching this forum a little before installing the pre-release. I really don't want any of my workspaces corrupted. What can I do to make sure this doesn't happen?

 

Also, will there be a 2nd pre-release put out later today with a few more bug fixes?

 

thanks.

Link to comment
Share on other sites

Here's a bug:

 

After installing v. 9, I checked for updates and downloaded an update to the OT in NT parallel database. As soon as it finished installing the updated module, Accordance 9 crashed. After restarting it, I logged in to Easy Install and downloaded the v. 9 starter package to get the additional non-English Bibles included in the starter package. After downloading, Accordance crashed as soon as it finished installing the modules. When restarted, the modules are installed and open without any trouble.

Link to comment
Share on other sites

Here's a bug:

 

After installing v. 9, I checked for updates and downloaded an update to the OT in NT parallel database. As soon as it finished installing the updated module, Accordance 9 crashed. After restarting it, I logged in to Easy Install and downloaded the v. 9 starter package to get the additional non-English Bibles included in the starter package. After downloading, Accordance crashed as soon as it finished installing the modules. When restarted, the modules are installed and open without any trouble.

I can verify this. I did the Easy Install for the Library 9 Premier upgrade. It downloaded the modules and installed the module but immediately crashed. I reopened A9 and the modules seem to be correctly installed (I saw and opened Ungers which is a new module for Premier 9 correct?)

Link to comment
Share on other sites

Just goes to show that we shouldn't jump on the bandwagon too soon. I can confirm that the startup session bug jinxed my workspace.

 

<sigh>

 

Ah well, I was meaning to tweak it anyway.

 

Here's a thought: I restored 8 and immediately regretted it. It took only an afternoon for me to be 'more comfortable' in 9.

 

When this stabilizes it's going to be an even more awesome product. Well done.

Link to comment
Share on other sites

I got the same thing going on (that bleedover off the right side of the screen).

Link to comment
Share on other sites

I can verify this. I did the Easy Install for the Library 9 Premier upgrade. It downloaded the modules and installed the module but immediately crashed. I reopened A9 and the modules seem to be correctly installed (I saw and opened Ungers which is a new module for Premier 9 correct?)

 

This happened to me too when installing the BDAG/HALOT bundle.

Link to comment
Share on other sites

Is this a bug, or do I just need some advice?

 

Here's the issue: When I amplify a bible verse to one of my favorite workspaces it opens a new window (which is normal). However when I drag that "mixed" window into the other workspace, that's when the weird stuff starts. When I try to amplify the next verse (moving from verse one to verse two, for example) with my 'favorite' workspace it opens a brand new workspace instead of producing the contents in the 'favorites' pane already created at the bottom of the page.

 

In the previous version I really liked the favorite workspaces. I could search for a verse in the favorite workspace and then tile (command-I) the contents. Now, it just crashes the entire application if I try to do that.

 

Also, I get some strange artifacts on the screen after I add stuff to a workzone (see on the top left side of the attached screenshot).post-126-128474986642_thumb.jpg

Link to comment
Share on other sites

Ok, I have one more bug posting to make. And then I'll be quiet.

 

Some of the sections from HALOT and NIDOTTE which I copied into my user notes now have the english fonts changed and the sizes changed as well. Is there an easy way to fix this (remove a preference file or something)? See attached screenshot. post-126-128475212551_thumb.jpg

Link to comment
Share on other sites

To everybody that has bad workspaces, if you can send them to me (Via PM, e-mail, or just attach to this forum), we can test them to see why they are getting corrupted and hopefully fix it soon. If I don't get any sample workspaces that are getting corrupted, it'll be much harder to find the bug, so please send them.

Link to comment
Share on other sites

To everybody that has bad workspaces, if you can send them to me (Via PM, e-mail, or just attach to this forum), we can test them to see why they are getting corrupted and hopefully fix it soon. If I don't get any sample workspaces that are getting corrupted, it'll be much harder to find the bug, so please send them.

 

Joel,

What are we looking for to tag a workspace corrupted? Is the bleed off issue an example?

Link to comment
Share on other sites

Joel,

What are we looking for to tag a workspace corrupted? Is the bleed off issue an example?

 

No, this is for the workspaces that become corrupted when loading into 9.

Link to comment
Share on other sites

I tried to upload the file to the forum here. But I get this warning:

 

"You aren't permitted to upload this kind of file"

 

Any other options for delivery?

Link to comment
Share on other sites

I tried to upload the file to the forum here. But I get this warning:

 

"You aren't permitted to upload this kind of file"

 

Any other options for delivery?

 

If you compress it as a .zip, it should be allowed for upload.

Link to comment
Share on other sites

Comparing my screen with Bryan's, mine doesn't bleed off as badly as his does, which is probably a font issue (I switched to Adobe Garamond years ago so that I could be just like David Lang :rolleyes: ).

 

post-34-128473764522_thumb.png

 

But at the very least, can I say how really nice it is to have BDAG in the same window as my text? No more lining up two separate windows!

 

 

Yep. Changing font cleared it up.

 

Though I was using the default font, so it might still need to be looked into for "it just works" reasons?

 

And yes, zones are a beautiful thing! Having both right there visible at the same time is a great thing.

Link to comment
Share on other sites

Thanks to everyone who sent me a workspace. To clarify a few things:

 

This is primarily concerned with the 'corrupting startup session' bug. Most of the other bugs we are aware of and can easily reproduce, but we need these corrupt workspaces to reproduce. However, the trick is that we need the workspaces before 9 corrupts them! So, for the people who claimed that when upgrading to 9, their startup session was hosed, can you use Time Machine, recall the pre-9 version, and send that to me? My e-mail is joel@accordancebible.com. Alternatively, you can post it to this thread, but you must compress as a .zip first. Thanks again, everyone.

Link to comment
Share on other sites

Found another one. It may or may not be a bug but I can't imagine that it's not.

1. Open Thompson Chain References. It opens in a horizontal position (Screenshot 1)

2. Grab Thompson window and slide it over into its Zone. It changes to a vertical position and halves the screen (Screenshot 2)

3. I grab the divider to resize and it seems to snap and lock into the position shown in Screenshot 3). Once it does this, I cannot resize the Thompson zone. It is locked and I have to move it back to the horizontal position and then bring it back. It seems that I cannot pick a size between the half screen or the position in the 3rd Screenshot. Shouldn't that be dynamic?

post-33-128477543919_thumb.png post-33-128477545135_thumb.png post-33-128477546043_thumb.png

Edited by Tom Castle
Link to comment
Share on other sites

When I open up and then try to print a Syntax pane, the print job shows up empty and the contents which should be in the syntax pane appear over my search text. post-15911-128477651705_thumb.jpg

Link to comment
Share on other sites

Found another one. It may or may not be a bug but I can't imagine that it's not.

1. Open Thompson Chain References. It opens in a horizontal position (Screenshot 1)

2. Grab Thompson window and slide it over into its Zone. It changes to a vertical position and halves the screen (Screenshot 2)

3. I grab the divider to resize and it seems to snap and lock into the position shown in Screenshot 3). Once it does this, I cannot resize the Thompson zone. It is locked and I have to move it back to the horizontal position and then bring it back. It seems that I cannot pick a size between the half screen or the position in the 3rd Screenshot. Shouldn't that be dynamic?

1_Horizontal.png 2_Vertical.png 3_Vertical Locked.png

 

This may be due to the presence of your small pane. When resizing, all panes are resized proportionally, so since that pane is at minimum width, it won't allow your search tab to go smaller. Try removing the pane, or increasing its width, then dragging the divider. I'm not sure why its snapping just yet, though.

 

When I open up and then try to print a Syntax pane, the print job shows up empty and the contents which should be in the syntax pane appear over my search text. Screen shot 2010-09-17 at 9.13.43 PM.JPG

 

Are you referring to printing the new syntax tree pane, or the syntax tab as shown in your screenshot?

Link to comment
Share on other sites

Easy Install is showing I have the Atlas Sampler to download. I already had it installed when I did the upgrade and the installed Atlas Sampler works fine in Accordance 9.

 

Even though I knew it was installed, I went ahead and told Easy Install to install it again. It downloaded the Atlas Sampler and appeared to install it. However, it is still showing as 'not installed' in Easy Install and available to download.

Link to comment
Share on other sites

I've not seen any of the display problems noted here, but I have found that any attempt to print when there's a syntax pane displayed (that's the new BHS-W4 Syntax for Genesis) then Accordance quits. It does quit with impressive speed, though!

Link to comment
Share on other sites

When I try to auto-scroll a text pane by Command-clicking on the up or down arrows, Accordance crashes!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...