Jump to content

Getting Unwanted Highlighting With Parallel Texts


Louis Lapides

Recommended Posts

I'm reading through the Books of the Maccabees (NETS) with the LXX Rahlfs in parallel. If I want to highlight one verse in the NETS with a yellow color, for example, nothing shows up in the LXX Rahlfs. I only see the yellow highlighting in the NETS.

 

However, if I highlight two or three contiguous verses in the NETS, those same verses are now highlighted in the LXX.  Sometimes the yellow highlights in the LXX are entire sentences or paragraphs based on my selection. Other times, the highlighting in the LXX is word by word. 

 

There must be some setting that is causing this to happen. I do not want any highlighting in the Greek text unless I am actually in the Greek text, not the English text. I am not sure whether this is a bug or I simple don't know the right way to configure my highlighting options.

Screenshot 2023-06-17 at 12.05.57 PM.png

Screenshot 2023-06-17 at 12.06.26 PM.png

Link to comment
Share on other sites

@Louis Lapides If you highlight a verse reference, it will be highlighted in all texts containing that verse. If you highlight the words in a verse (some or all), the highlight will only appear in the text module you are highlighting. To restrict it to one text take care not to include the reference.

  • Like 2
Link to comment
Share on other sites

 

Quote

If you highlight the words in a verse (some or all), the highlight will only appear in the text module you are highlighting. To restrict it to one text take care not to include the reference.

@Michael J. Bolesta Thanks Michael. I realize I should not include the verse reference when highlighting a text less all texts containing that verse be highlighted. But if I want to highlight two verses, I assume I would have to go through the process one verse at a time, but not include the verse reference. I'm looking for a way to highlight two contiguous verses in only one text. I tried holding down the shift key as well as the command key to see if I can highlight the words of a text without the verse reference. So far I've been unsuccessful. 

Link to comment
Share on other sites

Hi @Louis Lapides,

I might be mistaken, but my understanding is that it is not possible to do what you are trying to do. With the highlights, you can either select a word or a few words, and then it will only appear in that version, or you can highlight the verse number, which will highlight everything. So I don't think it would be possible to select an entire verse, or two verses, using shift or anything, since by doing so you would capture the verse and it would cross highlight.

 

I am sorry that I'm not able to be more helpful,

Kristin

  • Like 1
Link to comment
Share on other sites

@Louis Lapides try Window>Highlights>Live Highlight. Select the highlighter and style from the floating Highlight palette. That tool appears to do what you wish.

  • Like 2
Link to comment
Share on other sites

@Michael J. Bolesta Thanks Michael, but I think what was shared by @Kristin is what most applies here. What I want to do cannot be done. Since  

I am selecting two to three sections of text, the verse references are included so what I am selecting for highlighting purposes goes across all the texts in my parallel panes. I have not seen a workaround. I'll just select and highlight one verse at a time leaving out the verse reference. But thanks for following up. 

Link to comment
Share on other sites

@Kristin you shared exactly what I've concluded myself.  Thanks for your insights. 

  • Like 1
Link to comment
Share on other sites

@Louis Lapides I opened live highlight and selected highlighter from the floating palette (lower left). I dragged over the first three verses of 3Mac 6 in a workspace like yours. Only the English verses in NETS were highlighted, not the LXX. See screen shot:

 

Screenshot2023-06-18at4_11_03PM.thumb.png.867b4add1901b6b2bd8fd979cee37412.png

Link to comment
Share on other sites

Posted (edited)

@Michael J. Bolesta  I see exactly what you suggesting. Micahel, it all makes perfect sense. However, when I go through the same steps the text in the parallel setup, the adjoining text becomes highlighted. This is why I think there is a setting I have not configured correctly. But I appreciate your attempts to help me.   Perhaps @Nathan Parker can show me what I am doing wrong. Michael, you helped me tremendously. There's some small tweak I am missing. 

Edited by Louis Lapides
Link to comment
Share on other sites

Let me ask a team member on this one.

Link to comment
Share on other sites

One of my team members asked to try this: If you highlight just the words of a verse and not the reference itself it does not cross highlight across other translations. But if you have the reference itself selected, it does highlight all the translations. Could this be it?

Link to comment
Share on other sites

Thanks for checking this out @Nathan Parker. Yes, if I only highlight the words of the verse and not the reference itself, it does not cross-highlight across other parallel translations. If the reference is selected, it will highlight all the other parallel texts.

 

What I am trying to do is highlight several contiguous verses in a text, and then apply the yellow highlighting to the text I am selecting only without cross-lighting. But when one tries to highlight the text from one verse to the next, the verse references are included. Consequently, the texts in the parallel versions are highlighted as well.

 

What I was hoping was a way to not include the verse references and highlight 2-3 verses at a time. I tried using all the usual suspect key combinations: Shift, Command, and Option keys. Nothing made a difference. 

Link to comment
Share on other sites

Thanks for the feedback! Let me ask again about this.

  • Like 1
Link to comment
Share on other sites

Hi Louis,

 

Try this:

 

One possibility is to hide verse highlighting in the Text Display in the text he doesn’t want to see the highlights in. Set it from within the Parallel window, not in the overall Preferences.

 

If this still doesn't do what you need, I guess we'll need to put in a feature request for what you're wanting to do.

PastedGraphic-1.png

  • Like 1
Link to comment
Share on other sites

@Nathan Parker the solution you offered does work. However, the highlighting I purposely inserted into the Greek text (LXX) from other previous studies no longer shows up. Furthermore, when I turn verse highlighting back on, then the sections of the text I didn't want to be highlighted in the cross highlighting situation, now return showing the yellow highlights. I'm sorry if I am confusing you.  Yes, I think this is a feature that should be added n the future. 

Link to comment
Share on other sites

Thanks! If someone else here has a workaround, I'll hope they chime in (highlighting isn't something I do a ton of, so I don't have a great answer for you). If it turns out we don't have exactly the feature you need, then if you'll post in "Feature Requests", I'll get it logged on my list.

  • Like 1
Link to comment
Share on other sites

11 hours ago, Nathan Parker said:

Thanks! If someone else here has a workaround, I'll hope they chime in (highlighting isn't something I do a ton of, so I don't have a great answer for you). If it turns out we don't have exactly the feature you need, then if you'll post in "Feature Requests", I'll get it logged on my list.

 

@Nathan Parker Please check out Live Highlight. As I described above, it only highlights the search text, not the parallel, at least on my MBP. @Louis Lapides said it did not work for him. I am curious if this is peculiar to one or the other of us. The way Live Highlight functions for me is not a workaround.

  • Like 2
Link to comment
Share on other sites

@Michael J. Bolesta Will do. @Louis Lapides what OS version are you on? I'll give Live Highlight a test on my system and compare with yours.

  • Like 1
Link to comment
Share on other sites

On my 2014 MacBook Pro (Big Sur 11.7.7) and Accordance 14.0.6 I get the results Michael got and the behavior Louis seeks.

 

—Joseph

  • Like 3
Link to comment
Share on other sites

@Nathan Parker @Solly @Michael J. Bolesta I’m on macOS Ventura on a 2021 MacBookPro with an M1 chip. My workaround is to highlight each verse one by one. As long as I do not include a verse reference, I’m good. But once I decide to highlight two to three verses consecutively in the English text, the highlighter will use the cross parallel feature and highlight the Greek text in parallel. 
 

I just tried the live highlight function in a NT text and a LXX passage, and I got the results I wanted!!!

 

I assumed Live Highlight is the same as the standard highlighting tool. Obviously, I misunderstood all the attempts made to help me. 
 

Can someone explain the difference between the standard highlighter and the Live Highlight feature? Thanks to everyone who stuck in there with me until I got what everyone was saying to me. 

Link to comment
Share on other sites

1 hour ago, Louis Lapides said:

Can someone explain the difference between the standard highlighter and the Live Highlight feature? Thanks to everyone who stuck in there with me until I got what everyone was saying to me. 

 

I think this page from the help files may answer this question: https://accordancefiles2.com/helpfiles/14-macOS/index.htm#t=mac_14%2Fcontent%2Ftopics%2F05_dd%2Fhighlight_words.htm&rhsearch=highlight&rhhlterm=highlight highlighting highlights highlighted

 

Link to comment
Share on other sites

I have a M2 MacBook Air on the way. I'll test this on both the MacBook Air when it arrives plus my Intel iMac Pro to make sure there isn't any difference between processor types (there shouldn't be).

  • Like 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...