Jump to content

Multiple Issues with Text and Tool Display and Settings


Lorinda H. M. Hoover
 Share

Recommended Posts

Mac Monterey 12.6.1; Accordance 14.0.0

 

I'm seeing a whole lot of issues with Text and Tool display display settings.  Some of them I've seen reported elsewhere, but I want to list everything I'm seeing (at least that I can remember) in one place:

 

1) Biblical texts are defaulting to Red text.  This was never the case for me before Accordance 14.  I can change the settings in either Accordance>Preferences>Text Display or Display>Set Text Display (aka Command-T), and the text color will correct.  But it will not hold if I change texts and change back.   For example, I have the CEB up and set the text display to black.   If I then set the text pane to the NRSVS, that text will be red.  If I shift back to the CEB, it will be red.  If I use Command-T again, none of the changes I made to the Text Display have stuck; it has reverted to the red setting.  Initially, it seemed as though this happened even when I set text color as default for a particular text.  But now setting a default setup seems to hold. 

 

2) Even when I choose named colors from the drop-downs for various text settings, the next time I return to the Set Text Display menu, the drop-downs say "Custom"; even if the colors stay the way I set them.

 

3) The Line spacing slider is greyed out and will not move.  This is true for both text panes and tool panes/tabs.

 

4) The line spacing box where one can enter a number does not work consistently, nor do numbers stay in the box.  Sometimes the choice of a number tightens the text very close together; sometimes is spaces it out.  most of the time it does nothing.  Also, the sample text does not match the actual text in terms of line space.  This is true in Texts and Tools

 

5) If I choose a named theme in Set Text Display (e.g. Honey); the theme, the next time I pull up "Set Text Display," it will say I have chosen the "Default" theme. (This is true even if I have not specified that theme to be the default for that text)

 

6) If I click "Customize Theme" in the "Set Text Pane Display" dialog, and then choose a background color, the background colors do not correspond to their names.  For example: "Black" shows an orange background.  White shows a black background; Newsprint is Brown;Mint is darker brown; Rose is Magenta--I'm sure it was lighter before; Sky is Red.   This is true both in Texts and Tools

 

7) in Tools, the "Text" and "Alternate Text" dropdowns under the Hypertext section of Set Tool Display show ---------.  I can set them to texts, but the next time I open Set Tool Display, they are back to --------.

 

8 ) In Tools, if I click "Customize Theme" in the Set Tool display dialog, and then change the color of Search highlighting, doing so will change the color of the Hypertext links, not the highlighted search terms.  This can been seen in the sample box and in the text after clicking ok.  The Hypertext color drop-down also works, so that can be corrected, but there is currently no way to change the color of the search highlighting in tools.  The Style drop-downs under these two sections work correctly.  

Edited by Lorinda H. M. Hoover
typos and lack of clarity
  • Like 4
Link to comment
Share on other sites

2 hours ago, Lorinda H. M. Hoover said:

Mac Monterey 12.1; Accordance 14.0.0

 

I'm seeing a whole lot of issues with Text and Tool display display settings.  Some of them I've seen reported elsewhere, but I want to list everything I'm seeing (at least that I can remember) in one place:

 

1) Biblical texts are defaulting to Red text.  This was never the case for me before Accordance 14.  I can change the settings in either Accordance>Preferences>Text Display or Display>Set Text Display (aka Command-T), and the text color will correct.  But it will not hold if I change texts and change back.    If I then set the text pane to the NRSVS, that text will be red.  If I shift back to the CEB, it will be red.  If I use Command-T again, none of the changes I made to the Text Display have stuck; it has reverted to the red setting.  Initially, it seemed as though this happened even when I set text color as default for a particular text.  But now setting a default setup seems to hold. 

 

2) Even when I choose named colors from the drop-downs for various text settings, the next time I return to the Set Text Display menu, the drop-downs say "Custom"; even if the colors stay the way I set them.

 

3) The Line spacing slider is greyed out and will not move.  This is true for both text panes and tool panes/tabs.

 

4) The line spacing box where one can enter a number does not work consistently, nor do numbers stay in the box.  Sometimes the choice of a number tightens the text very close together; sometimes is spaces it out.  most of the time it does nothing.  Also, the sample text does not match the actual text in terms of line space.  This is true in Texts and Tools

 

5) If I choose a named theme in Set Text Display (e.g. Honey); the theme, the next time I pull up "Set Text Display," it will say I have chosen the "Default" theme. (This is true even if I have not specified that theme to be the default for that text)

 

6) If I click "Customize Theme" in the "Set Text Pane Display" dialog, and then choose a background color, the background colors do not correspond to their names.  For example: "Black" shows an orange background.  White shows a black background; Newsprint is Brown;Mint is darker brown; Rose is Magenta--I'm sure it was lighter before; Sky is Red.   This is true both in Texts and Tools

 

7) in Tools, the "Text" and "Alternate Text" dropdowns under the Hypertext section of Set Tool Display show ---------.  I can set them to texts, but the next time I open Set Tool Display, they are back to --------.

 

8 ) In Tools, if I click "Customize Theme" in the Set Tool display dialog, and then change the color of Search highlighting, doing so will change the color of the Hypertext links, not the highlighted search terms.  This can been seen in the sample box and in the text after clicking ok.  The Hypertext color drop-down also works, so that can be corrected, but there is currently no way to change the color of the search highlighting in tools.  The Style drop-downs under these two sections work correctly.  

 

Well written, and exactly the same behavior on Mac OS 12.6.1

 

 

  • Like 1
Link to comment
Share on other sites

I have a MacBook Pro M1 with Ventura OS v13.01 and I have applied the Accordance v14.01 update but there are still issues with appearance, especially in tool display options and user notes.

 

Overall, there is quite a bit of lag and spinning beach ball when applying settings

 

text display settings

the text display option setting seems to retain my settings except for the line spacing slider which sets the spacing but doesn't retain it with app restart. Also, the % box always shows 1% when starting the tools display option. It does change when moving the slide but doesn't retain the % number.
Also, when selecting Custom from the Theme dropdown, Accordance crashes

 

tool display settings

the font color and search highlighting are defaulting to a dark green in tool display option but upon Accordance startup the tool text is actually showing the same unchanged settings from before applying the update
No matter what color I set the font color in the tool options display setting, it is always the dark green in the tool options box and in the actual display when exiting the settings.
the hypertext color does change but doesn't stick upon app restart

 

In the User Note Display, the % box always shows 1% when starting the tools display option. It does change when moving the slide but doesn't retain the % number. the slider seems ok and settings seem to be retained though

 

BTW, is this running in rosetta for the M1 chip rather than for apple silicon?

Edited by Greg Terry
Add question and clarity
  • Like 1
Link to comment
Share on other sites

Also seeing most of these issues in 14.0.1 as well.

 

In fact, right after installing 14.0.1 and restarting Accordance my text display when from normal in 14.0 to bold in 14.0.1.

 

 

  • Like 1
Link to comment
Share on other sites

Update with 14.0.1.  Also, clarification:  My Mac OS is 12.6.1. In my post above I originally had a typo that misidentified the Mac OS #.  I have since changed it.  I am working on a MacBook, with a core i5 chip, not an M1 if that matters. 

 

1) this is still happening.  For a minute or so, it appeared to be fixed, at least in terms of global preferences for Text display.  The first few texts I cycled through reflected the text color change I made in Accordance>Preferences>Text Display.  But then text started reverting to red again, and when I checked the preferences, my choice had not stuck. 

 

2) Still happening

 

3) Still happening

 

4) Still happening

 

5) Still happening

 

6) Still happening

 

7) Still happening

 

8 ) Still happening (and if I remember correctly, this was listed as one of the fixes in the 14.0.1 update!)

 

 

  • Like 1
Link to comment
Share on other sites

14.0 / 14.0.1 is so far really buggy. It wasn't ready for general release. I am seeing that old spinning beach ball everywhere that I haven't seen on my computer for ages with any app.

Link to comment
Share on other sites

I concur that the "Spinning Beach ball of death" has become prevalent with both 14 and 14.0.1.

macOS 13.0.1

Edited by William Cross
Link to comment
Share on other sites

back to v13 for me until at least some of these issues are addressed.

Link to comment
Share on other sites

The same here !!

I updated to 14.0.1  and the same problems, red text, can not change hypertext...

 

Please fix it! 

 

I am going back to v. 13

I have to teach and I use it every day. I can't use like this. 

Link to comment
Share on other sites

14.0.2 update on these issues:

 

#2, 5, and 8 are still happening for me.

 

The remainder appear to be fixed.  Thanks!

 

I know in another thread Silas indicated that input about priorities was helpful.  In that regard #2 and #5 are minor, since they only involve what appears as the "chose" option in the drop-downs and don't seem to affect the display of the text or the tool.  In my opinion, they should probably be on the "when time allows" list.  #8 is more critical, since it does affect the display of tools, and since it means it is not actually possible to change the hit color in tools at the moment. 

  • Like 1
Link to comment
Share on other sites

14.0.2 still exhibits behavior #5, but more importantly, Accordance doesn't apply the Honey theme on start; that is the problem I'm most concerned about. Yes, Preferences shows "Default" (or "Custom" for User Tools) any time I open Text or Tools or User Notes Display panes (instead of "Honey" as I set them), but the big problem for me is that, although the little preview shows the Honey colors in all three of those Display config panes, the actual content window shows white on charcoal. The color scheme preferences are still not being saved and restored in 14.0.2. See screenshot attached, where you can see the preview not matching what's underneath the Preferences dialog; I could have made 3 screenshots of the three Display config panels, and they are all the same: all show Honey in the preview, none show Honey selected in the dropdown, and all 3 types of content panes are white on charcoal.

 

We also are now (not in 14.0.1, yes in 14.0.2) getting a beach ball after pressing OK to close Preferences, before going through the three Apply dialogs.

 

This is not a v14 deal-breaker for me, as I leave Accordance running all the time (although it is a pain when I install a new module or update the application); 3 resets and "Apply" presses, and I'm back to working. But it will be great to have it fixed. Also, I should add that while v13 did retain Honey theme (in my content windows) through restarts, it did NOT retain "Honey" in the dropdowns of Preferences panels (so #5 is an inherited bug).

 

Running Accordance 14.0.2 on macOS 12.6.1 on M1 Ultra.

 

For this screenshot: 1) Start up Accordance. 2) Open Preferences. 3) Select User Notes Display. 4) Take screenshot.

Acc1402 themes bug.png

Edited by Christopher Smith
  • Like 1
Link to comment
Share on other sites

Accordance 14.0.2 is still forgetting Appearance Preferences and changes text colors after the program is quit and restarted.
The Spinning Beach Ball appears after applying preference changes for Appearance and takes quite a long time for them to be applied. 

  • Like 1
Link to comment
Share on other sites

4 hours ago, William Cross said:

Accordance 14.0.2 is still forgetting Appearance Preferences and changes text colors after the program is quit and restarted.
The Spinning Beach Ball appears after applying preference changes for Appearance and takes quite a long time for them to be applied. 

I experience this as well. 

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...