Jump to content

Copying text gives wrong language for first line

John Brownie

Recommended Posts

Accordance 8.0.2, Power PC, OS X 10.5.3


When I copy or export text, the first line comes out in the wrong language. Here is what the first line looks like:


\id JON John.txt UTF8 John Mussau-Emira John Brownie 27/6/2008


and here is how it comes out:


ئضد حعن حعهن.تخت ظتط٨ حعهن مظصصاظ-غمضرا حعهن برعونضغ ٢٧/٦/٢٠٠٨


As you can see, it's gone to Arabic. It appears to copy correctly if I select the first line without the return, but if I include the return, it goes to Arabic. If I have several lines selected, only the first comes out in Arabic.

Link to comment
Share on other sites

We have struggles with many font issues in the User Notes (I assume this is where you are copying from). It looks like you have found another, and we will try to track it down.


Does it happen whatever line is first in your selection, first in the user note, or is it just this line?

Link to comment
Share on other sites

Hi John,


To reproduce the problem you are having, we will need more information about the text you are trying to copy.


Could you post pictures of the working/non-working selections in your User Notes? (this probably is the best way to show what selections work and the selection that does not work). To take pictures, I recommend you type command-shift-4 and select an area just large enough to show the lines around the selected text.


Also, it would be helpful to know the font name and styles used in and around your selection.



Link to comment
Share on other sites

OK, I did some more investigating of the problem. It appears that it was just that one line that was the problem, for some reason. If I exported other text from the same area of the user notes, everything worked fine. Changing the text on that line left it coming out in Arabic. What fixed it was simply to delete the entire line, then retype it. That apparently picked up the correct formatting from the second line.


I've been working on this notes file for several years, so it's been through multiple versions of Accordance, and I've seen some font issues at various points, but this was one of the first that I was able to reproduce. Other similar ones have had the reference line turn into Hebrew. Otherwise, fonts have changed from one Roman font to another, but that's not as much of a hassle.


I know that doesn't make it easy to find the problem, but I'm satisfied at the moment that I can get a solution pretty easily by myself when it happens. Thanks for asking questions that helped me to get a solution.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...