Jump to content

Copy and Pasting Hebrew

Lorinda H. M. Hoover

Recommended Posts

I am struggling a little bit with apparently inconsistent results copying Hebrew from one window in Accordance and pasting it into User Tools and User Notes. Sometimes when I copy and paste, the Hebrew text is pasted correctly. Other times, when pasted in, the letters appear in reverse order. This happens during the same session, with no changes made in preferences. I have discovered that the length of time between when I copy a word or phrase and when I paste it appears to make a difference.


If I copy and then paste immediately after shifting windows, it (usually?) pastes correctly. If, however, I copy a word or phrase, shift windows, and then type additional text in my User Tool or make other edits before pasting, the letters are sometimes (often? always?) reversed.


I use Butler to remember the last 7 items on my clipboard. Butler numbers the "recent clipboards" from 0 to 6, with 0 being the text most recently copied (i.e. the text that is pasted if I use command-v). The 0 entry usually displays correctly, but the other entries are inconsistent. Some show the Hebrew text in the correct order, but a different font, others show the phrase in yehudit with the order correct, others in yehudit with the order reversed. All of them where copied to the clipboard in the same way, though maybe not from the same place in Accordance. I am attaching a screen shot so you can see what I mean. For some reason, though, the screen shot is very pale. Note that when pasting #5 back into Accordance, the letters which appear correctly in Butler's view, are reversed in the User Tool. when pasting #6 back into Accordance, a series of question marks appear in the User Tool (because #6 is unicode?).


Just to be clear, I'm not asking you to troubleshoot Butler; I completely understand that it is a third party program and I don't expect you to resolve issues with it. It's just that it provides an easy way for me (and hopefully you) to see how the Hebrew is showing up on the clipboard. If it is simply an incompatibility issue with Butler, then I'll just have to live with it or ask the developer if it is something he can fix. But since it happens with a simple cut and paste, I'm guessing it's not related to Butler.


I also noted some similar inconsistancies when pasting Hebrew words into an e-mail message this morning. (I use mail)


My preferences are set for Unicode export (which I need when copying and pasting into other applications).


Thanks for any light you can shine on this.




P.S. If I can find the time, I'll do some 'controlled' tests copying and pasting from different windows in Accordance and see if I can establish a pattern in that regard.


Link to comment
Share on other sites



I have encountered something similar before, however I do not use Butler. When I have seen this problem occur, it has happened after I copied some Hebrew, then went to a few other applications, before pasting into the word processor or whatever I had as a target. However, when I went from Accordance directly into the target application, no problems.


I have Accordance set to reverse the Hebrew in Yehudit for pasting. However, I noticed that in your screen shot some of the Hebrew looked to be Yehudit, whereas others looked to be another font, perhaps unicode. This would complicate identifying the problem.


Based on the experience I have had, I had concluded that the odd clipboard behavior was related more to OSX, and/or, other applications, rather than Accordance itself (which of course may not be the case, as this is a complicated issue). However, if this is the case, either Butler, or OSX, or another program could be messing up the Hebrew. Anyway, a suggestion is to try removing other applications from the equation, and see if the problem persists.





Accordance Development

Link to comment
Share on other sites



Thanks for a speedy reply. It is possible that moving from application to application is part of the issue. I was working primarily within Accordance today, but I sometimes accidentally hit command-tab instead of command-` when I want to shift between open windows. Thus I get shifted to a different application when I didn't intend to. I'll try to watch for that as a contributing factor in the future.


I noticed the yehudit vs. unicode differences in the Butler clipboards as well. This also happened when I pasted a couple of Hebrew words (copied from accordance) into an e-mail. Two of the words were yehudit and in the correct order. The other word was in some other font, but not in the correct order. Try as I might, I could not resolve the font differences, although I was able to manually retype the word that pasted in reverse.


While it can be a nuisance, it's not a huge problem for me. If I am able to identify more factors that seem to affect the inconsitencies, I'll post them here, on the off chance that it is an Accordance issue. Otherwise I'll presume that it is a Mac OSX issue.



Link to comment
Share on other sites

I did some experimenting tonight, and I have uncovered a pattern.


Copy a Hebrew word in Accordance. For this example, MLK

Move directly to an Edit User Tool pane and paste. Word pastes as MLK.

A check of Butler's recent clipboard menu shows KLM in the clipboard, but it pastes correctly into Accordance.


Now move to another application. Paste. If the app recognizes unicode, MLK will paste correctly in a unicode font.

A check of Butler's clipboard menu shows MLK in a unicode font as the 0 level (i.e. current OSX) clipboard; KLM in yehudit is clipboard 1.


Now return to Accordance and paste into the user tool. It pastes a KLM.

A check in Butler's recent clipboard menu shows MLK in yehudit at the 0 level clipboard; MLK in unicode in clipboard 1, KLM in yehudit in clipboard 2.


Move to another app and paste again.

Word will paste in as MLK in yehudit (!).

Butler will show KLM in yehudit in level 0, MLK in unicode in clipboard 1, MLK in unicode in clipboard 2, KLM in yehudit in clipboard 3.


Return to Accordance and paste. It pastes as MLK.


After this point, each shift from Accordance to another app flips reverses the word order from the previous time, but always in yehudit.


In point of fact, it is not necessary to paste into another app for the changes to occur in the clipboard.


So, I draw the following conclusions:

1) This is not a bug, but a feature of Accordance, designed to paste as yehudit in Accordance and unicode in other apps (perhaps per my export settings).

2) The reversal I was seeing was due to accidently shifting programs instead of windows. (command-tab instead of command=`)

3) If pasting Hebrew into Accordance results in reversed characters due to shifting to another application (on purpose on by accident), one quick fix is to briefly shift to another app and return. The text will then paste correctly.

4) The unicode shift occurs only the first time one moves from Accordance to another app. Further shifting will only swap directions of the word in yehudit, until a new word is copied.

5) words in yehudit will appear reversed in the clipboard but paste correctly (at least in Accordance), and vice versa.


Have I managed to thoroughly confuse everyone yet? Believe it or not, this has clarified things for me. Now I know why I was having trouble and what to do about it. In addition, I am impressed that Accordance is able to track whether the word needs to be pasted in yehudit or unicode, without any intervention from me.


Consider the mystery solved. :D

Link to comment
Share on other sites

  • 3 months later...

Actually this mystery is not solved.


Using either the tagged Hebrew text or the text with the BHS apparatus, here's what happens.


I format text to display as paragraphs.


I selelct and copy a section of text, say Joshua 6:1-5


I switch immediately to Word or to Pages and past the text


I change the font to HebraicaII and the text looks okay except that verse 4 is in reverse order.


Here's the key: the direction problem only happens if I have the text set to display in Accordance "Show Text As Paragraphs." When I have it set to display as separate verses, no problem.


I'm using version 7.4

Link to comment
Share on other sites

It's the brackets for the ketiv/qere that are causing the problem in your example, although I see that export in paragraph mode also reverses the English book name. Sigh! We'll try and fix it, but really, Hebrew doesn't have paragraphs, which is why this bug has not been noted before, it's so obscure!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...