Jump to content

Julia Falling
 Share

Recommended Posts

I have found two issues that have shown up with 10.1.

 

1 - Keyboard shortcuts Cmd-B for bold and Cmd-I for italics do not work in the edit window for my user notes.

 

2 - Set Text Display is essentially non-operational. See shot.

 

post-330-0-49356000-1352990723_thumb.png

 

I have quit and restarted Accordance but it didn't help.

Link to comment
Share on other sites

Julie, I'm not reproducing either of these issues. Command-B and Command-I Work, and my Set Text Display looks fine. When you opened the Set Text Display, was it that big, or did you press the Customize Theme button? Also, does it clear itself up if you Click Hide Customization?

 

In the Edit window, does clicking the B/I buttons work, just not the command keys? And you are sure this worked in 10.0.5?

Link to comment
Share on other sites

When I opened the Set Text Display, this is what it looks like. Note that what's in the box does not reflect my current text display.

 

post-330-0-88626000-1352992089_thumb.png

 

When I Customize Theme, I get the larger window with parts missing.

 

The buttons work in the edit window, but the keyboard shortcuts do not. The keyboard shortcuts work elsewhere.

 

It all worked in 10.05. I add and edit notes daily.

Edited by Julie Falling
Link to comment
Share on other sites

Julie, I just tested my system and everything is functional for me under 10.1. The keyboard Cmd-B and Cmd-I worked perfectly in editing notes and when I try the Set Text Display everything is there as normal. My guess is that you have a corrupted preferences.

Link to comment
Share on other sites

Sounds like it. And I really love my Preferences. Do I toss the whole thing? In both places? It's in both Application Support > Accordance and Preferences > Accordance Preferences. Accordance will recreate both files, right?

 

Joel, I rebooted, and the Set Text Preferences looked fine until I did the Customize Theme. The right half was still non-functional. So I cancelled and tried again and had the same problem as before.

 

The keyboard shortcuts still don't work. You guys tell me what to throw away and I'll do it.

Edited by Julie Falling
Link to comment
Share on other sites

Don't start trashing preferences just yet! First, does the Set Text Display fail with all texts, or just your NASB? Try it on a text you don't use that regularly.

Link to comment
Share on other sites

It fails for tools and texts whether used frequently or rarely.

 

I quit Accordance then restarted. Accordance didn't remember my session, but opened with my default text. I did Cmd-T to Set Text Preferences and got this.

 

post-330-0-94068600-1352995444_thumb.png

 

I tried to Customize Theme and got this.

 

post-330-0-50646100-1352995486_thumb.png

 

I cancelled and tried again and got this.

 

post-330-0-50646100-1352995486_thumb.png

post-330-0-05542200-1352995528_thumb.png

Edited by Julie Falling
Link to comment
Share on other sites

Here's some more data.

 

I quit Accordance again and restarted it. Got the default text when it reopened. I opened my User Notes and tried the keyboard shortcut in the edit. All worked well. Then I tried to Set Display. Still weird. I tried to edit a user note, having not changed anything in the window. The keyboard shortcuts were not longer working.

 

One thing that is working is that the preferences I have set for my texts and tools is fine. They all open in the fonts and colors that I have chosen.

Edited by Julie Falling
Link to comment
Share on other sites

A few days ago I had the same problem with Cmd-B for bold and Cmd-I for italics on my user notes. It would work fine with the buttons but not with the shortcuts. That was 10.0.5. I hadn't noticed it before. Today I tried it still on 10.0.5 and the shortcuts were OK.

Link to comment
Share on other sites

Thanks the the reports. I'm looking into the issue when I can, but ETS/SBL takes up most of the time! I'm curious: When you are in your user notes edit window and you have some text selected to make Bold, if you instead go to the Display -> Style menu, are those items available, do they have the command keys attached to them, and does selecting them make the items bold/italics/etc.?

Link to comment
Share on other sites

Joel - If I go to Display -> Style I get a dead end. No commands or selections are available. I never had the problem before the update to 10.1.

Link to comment
Share on other sites

I can't reproduce this, sorry.

Link to comment
Share on other sites

Ken, I can't reproduce this on the new Mac mini, either. I think it's time to trash the Preferences on the MacBook Pro. Do I toss both folders? Will Accordance recreate them? If I have to do this, I'm going to wait until tomorrow morning. It's late here.

Link to comment
Share on other sites

Hi Julie,

Joel would be the one to advise best, but can I suggest a graded approach? Don't trash anything. Drag the ~/Library/Preference/Accordance Preferences/User (Tools,Items,Notes) onto your desktop, and then relaunch ACcordance. That should recreate those prefs (only). If that doesn't work, try taking all the files out to the Desktop. You will have to validate your accordance install again, but it should therefore clean up any pref problems.

 

If there's still a problem, then it's probably not a prefs problem, and I hand it back over to Joel. But you also haven't lost any of your preferences! :-)

לילה טוב

Edited by Ken Simpson
Link to comment
Share on other sites

OK. Must have been a brain freeze, or maybe a brain cloud? Senility?

 

After I had my Mac mini set up and running, I had moved almost my entire MBP Documents folder to it. Accordance was/is working perfectly on the Mac mini, so connected the MBP and mini over our network and moved both the Accordance Preferences folders to the MBP. Rebooted. Opened Accordance. Everything is now working perfectly.

 

I did have corrupted preferences. The only thing that wouldn't open was my prayer journal Workspace. The User Tool, however, was intact, so I opened it and named the Workspace.

 

Thanks for the moral support, guys. And Joel, you can stop looking for a flaw in the code. The problem was at my end. Glad I didn't trash those preferences!

Link to comment
Share on other sites

Sorry, guys, it's back. Restarting Accordance "cures" the problem, but some bad stuff seems to accumulate through use. After a while, the Set Text Preferences and User Notes edit go awry. I don't think it's just me.

 

I'll try using Accordance on the mini extensively over the next few days and see if I can mess it up, too.

Edited by Julie Falling
Link to comment
Share on other sites

This is still an issue, and everything goes bad at once. The Set Text Display becomes non-functional, the keyboard shortcuts for bold and italics in the Edit Under Notes stops working, and also the Tip-Tap in BetterTouchTool quits even though other gestures will still work. If I quit Accordance and restart, everything works again.

 

Since most of my Text Display Preferences have been fixed, I usually spot the problem with either the edit window or BetterTouch Tool.

Link to comment
Share on other sites

The problem showed up again yesterday. These are the things that were non-operational this time: Cmd-B/I in the User Tools edit, Set Text Display Prefs, and File -> Save As to save a Workspace.

 

I quit and restarted Accordance and everything worked again.

 

Am I the only one experiencing this?

Link to comment
Share on other sites

  • 2 weeks later...

The problem persists in 10.1.1. I detected this morning when Better Touch Tool had stopped working. I then checked the Set Text Display Preferences, and the window did not show the custom display I had right in front of me. I didn't check the Cmd-B/I in the User Notes window, figuring it had probably cut out, too. Quit and restarted Accordance and everything reset and all is working properly now.

 

Accordance 10.1.1

OS 10.8.2

MacBook Pro late 2008 unibody

2.53 GHz Core Duo

8 GB RAM

750 G Hitachi HD w/400 GB available

Link to comment
Share on other sites

Hi, Julie, I'm sorry we couldn't get your issues resolved in 10.1.1. We needed to rush it out there a bit cause of some critical MERGE and diagram bugs. I'll take a more in depth look at your issue pretty soon! I'm glad a restart helps, but I'm sure it is very annoying.

Link to comment
Share on other sites

In light of everything else that is going on, I understand. A restart does clear it up. It's not like I'm an author with a deadline!

 

I'm not finding a trigger for the problem. It seems that something just gets crudded up and a restart cleans out the crud. Don't you just love it when posters get technical?

Link to comment
Share on other sites

OK. I've found at least one trigger. If I go into Reading Mode, then back to my previous workspace, the first thing I noticed was that BetterTouch Tool tip-tap had cut out, then checked Set Text Display and it was out, too. Tried the edit window of User Notes, and Cmd-B/I was non-functional. Very odd indeed, but at least now I've discovered at least one trigger. As before, a quit and restart of Accordance fixes everything.

 

Accordance 10.1.1

OS 10.8.2

Link to comment
Share on other sites

Still trying hard to reproduce this over here! So, it reproduces for you every time if you go in and out of reading mode? What other type of things are you doing, do you recall? Such as opening Instant Details popover, accessing things in the Library, etc.

Link to comment
Share on other sites

Mostly ID popup and editing User Notes (since the last restart), but I also regularly Amplify to a lexicon or Bible dictionary. Since I use BetterTouch Tool when having my devotional time (to go from tab to tab using the tip-tap), I think I detect the corruption shortly after it happens. The other gestures of BetterTouch Tool continue to work.

 

I can zip the workspace and attach it if that would help (probably best to eliminate my User Notes from the tabs first).

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...