Jump to content

Accordance 10 has gone haywire


Randy Cue
 Share

Recommended Posts

Hi All,

 

I think we need to revisit this topic.

 

This happened to me again today and I think I know why it did it now.

 

The first time this happened to me I stated that I thought it might have been my fault. That is not the case this time around and I doubt it was the first time. It is a bug of some kind in the Library Pane. Yesterday I was rearranging and alphbetizing Texts and Tools in the Library Pane. Last night I shut my iMac down to move it (rearranging my office space in my home). I plugged it back in this morning and fired it up. Started Accordance and it told me one of my Reference books was not available. I had a bad feeling about that as that is what it did the first time this happened. Needless to say it had happened again. Moved my books around the same way it did the first time. The first time this happened I had rearranged and alphebtized the same as this time. I changed no other settings so the problem is definately in the Library Pane. I followed Helen's directions above and got it fixed again. Right now I am afraid if I rearrange (prioritize) and alphebtize my tools it may do this again.

 

I certainly hope you guys can duplicate this error and get this fixed.

 

Blessings,

Tim

Edited by twbeining
Link to comment
Share on other sites

We looked hard in the code of the Library and did fix a couple of errors for 10.0.4 but we are not sure we got this fixed as it is not reliably reproducible. Please post any reports of it happening with 10.0.4.

 

The easiest way to fix it is simply to remove tools in the Library that are in the wrong place, and use the Add Modules at the bottom to add them back.

 

So sorry for the hassles.

Link to comment
Share on other sites

I know its been a long day, but did you mean 10.0.2 instead of 10.0.4? That's the latest available according to mine.

Link to comment
Share on other sites

Thanks Helen!

 

I hope you got it in 10.0.4. When will that update be out?

 

Blessings,

Tim

Link to comment
Share on other sites

Tony,

 

That is an interesting thought. If she meant 10.0.2 then the problem is not fixed as I am running 10.0.2. If not and she meant 10.0.4 then I look forward to the next update.

 

Blessings,

Tim

Edited by twbeining
Link to comment
Share on other sites

Helen had a post (that I cannot find) indicating that 10.0.3 was awaiting app store approval and that they were working on 10.0.4

Link to comment
Share on other sites

Tony,

 

By the look of the information on the download page in your link, I would think 10.0.4 update will be out sometime today.

 

Blessings,

Tim

Edited by twbeining
Link to comment
Share on other sites

Thanks Joel,

 

I hope this fixes it. If not I will do my best to keep track of what I do that causes the problem.

 

Blessings,

Tim

Link to comment
Share on other sites

Hi All,

 

This has now happened a third time. I updated to 10.0.4 yesterday and that did not fix the problem. I do now know exactly what I did to cause it and I hope this will help the gang at Accordance to fix it.

 

I decided just a little while ago to try to alphabetize my Reference Tools in the Library Pane again after updating to 10.0.4. I did the same thing I did the other two times. I clicked on Reference Tools to give it focus, then I right clicked to get the menu and selected Alphabetize. When I did I saw the tools section in the Library move into alphabetical order and I got that bad feeling again. All the books had moved again.

 

Needless to say I once again followed Helen's directions to fix the problem.

 

I am thinking that trying to alphabetize at the Reference Tools folder level in the Library Pane is not a good thing to do and that is what caused the problem. Alphabetizing inside the folder works just fine and did not seem to cause a problem. Moving books up and down in the folder to prioritize caused no problem either.

 

Hope this helps you folks at Accordance track down and fix this problem.

 

All of you at Accordance are the best! Thanks for an excellent program!

 

Blessings,

Tim

Edited by twbeining
Link to comment
Share on other sites

Thank you, and thank you again, Tim for finally diagnosing the issue! I had some theories about alphabetization, but didn't realize people were selecting 'Reference Tools' itself to Alphabetize, not one of the inner modules. Thanks to your report, I've finally been able to track down and fix the bug. We'll probably be posting 10.0.5 a bit ahead of schedule to get this bug fix out ASAP. Thanks again.

Link to comment
Share on other sites

Joel,

 

I'm just glad this was a good enough description to help you figure this one out. I am pretty new to Mac and Accordance. My only hope was that I could remember what I did and be able to explain it well enough for you to understand.

 

Thank you Joel and everyone else at Accordance for all you do!

 

Blessings,

Tim

Link to comment
Share on other sites

  • 2 weeks later...

Any further word on when the 10.0.5 update will be arriving. I've bumped into this same bug numerous times today and I finally went online to see if anyone else was having the same issue with their Library pane and Tools not showing up correctly (after trying out the alphabetize feature). I'm eagerly awaiting the 10.0.5 update which will hopefully truly squash this bug. :)

Link to comment
Share on other sites

We have just posted the release candidate and you are welcome to download it here. I am not sure that it will fix a corrupted Library but it should prevent a further corruption. You can remove any modules from the Library that are showing up in the wrong section, and then use Easy Install to reinstall them. Please let us know how it goes.

Link to comment
Share on other sites

I installed that version and things appear to be fine so far. But I did notice that the Library now seems to be a panel that appears on top of my current workspace rather than appearing along the left side in a new column pushing my workspace to the right.

 

I'm not sure how I feel about it overlapping my workspace. My first response was to try to figure out how to remove that "feature" but that could possibly be because I instinctively don't like change. ;-) I'll have to think about that a bit more to see if I like that or not.

 

Thanks for the DL link to 10.0.5.

Link to comment
Share on other sites

This has been there since version 10.0. You can now open your library as a zone or popover. Depending on your settings in Preferences -> Appearance -> "Always Show Library as Popover", it will default to either zone or popover. You can then hold down the shift key to get the other one.

 

However, if there isn't room to open it as a zone, it will always be a popover, and this is what I imagine is happening for you now. Check to see that you don't have any zones or panes that are so narrow they can't get any thinner.

Link to comment
Share on other sites

That makes sense. I will have to check it out next week when I'm back on my work iMac. I'm sure I had too many zones open already. Thanks for the reply though!

Link to comment
Share on other sites

10.0.5 is now released via In-App Update, that should once and for all resolve this issue!

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...