Jump to content

New Widget Doesn't Work


xcfamily
 Share

Recommended Posts

When I upgraded to 9.4 the Accordance widget would not let me insert verses into Word. I've never had this problem. I read that a fix was in the works and just downloaded the new widget. I tried to insert text from the widget again and get a "can't find Accordance error. The error gives me a window to find Accordance which is located in the standard install applications folder. I select Accordance and it takes me back to the widget. Still doesn't work. Every time I try to insert text it tells me it can't find Accordance. HAs anyone else been having this problem?

Link to comment
Share on other sites

Did you try going through the troubleshooting tips in the widget readme? They include closing each instance of the widget and removing its preferences.

Link to comment
Share on other sites

I am also having problems with the widget.

 

1) Each time I enter a verse for it to find, it says "loading" and then dumps me back onto my desktop (if I open the dashboard again, the text I searched for is displayed as usual).

 

2) If I open Accordance after having used the widget, my Workspace window is inexplicably missing, and nothing I do seems to be able to bring it back.

 

I have taken the widget off for now since it is causing so many problems.

 

Also, how does one do what the read me suggests and delete that file from ~Library/Preferences? I can't seem to find it anywhere. I am a new Mac user as well as a new Accordance user, so forgive me if this is a dumb question.

Link to comment
Share on other sites

A new mac user also? Welcome to mac then! In the latest release of the OS X operating system (which I assume you have being new to Mac), Apple has hidden the Library folder. To access it, one way is to hold down on the option key when clicking on the "Go" menu in the Finder. You can also google hidden library folder in Mac Lion to find other ways.

Levi

 

 

Also, how does one do what the read me suggests and delete that file from ~Library/Preferences? I can't seem to find it anywhere. I am a new Mac user as well as a new Accordance user, so forgive me if this is a dumb question.

Link to comment
Share on other sites

A new mac user also? Welcome to mac then! In the latest release of the OS X operating system (which I assume you have being new to Mac), Apple has hidden the Library folder. To access it, one way is to hold down on the option key when clicking on the "Go" menu in the Finder. You can also google hidden library folder in Mac Lion to find other ways.

Levi

 

 

Okay, thanks. The first option (holding down Option key in the Go menu) worked fine.

Link to comment
Share on other sites

I am having an issue with the widget it works every once in a while for auto pasting. Can't get it figured out as why it will or why it won't. Read the read me and would reinstall as it says but can't find the widget.com.oaktree etc in the Library preference file in Lion. Is there anyone else have the widget work sporadicly? Thanks for the help Pat

Link to comment
Share on other sites

Pat:

I am going to guess that you are in the wrong Library folder (there are two of them). As discussed above, in Lion, Apple went and hid the user library folder (the one you want).

To see it, open the Finder and hold down on the option key while clicking the "Go" menu.

Hoping I guessed right,

Levi

 

 

 

I am having an issue with the widget it works every once in a while for auto pasting. Can't get it figured out as why it will or why it won't. Read the read me and would reinstall as it says but can't find the widget.com.oaktree etc in the Library preference file in Lion. Is there anyone else have the widget work sporadicly? Thanks for the help Pat

Link to comment
Share on other sites

I tried removing the widget and all the widget files in the preference folder then re downloaded and reinstalled the widget and it still does not paste. Now I have not got it to paste at all now???? Thanks for the help. I need this to work soon it was something I used all the time.

 

Pat

Link to comment
Share on other sites

Pat:

 

There are so many variables here. What system are you on? Have you upgraded to Accordance 9.4.1 (it's possible that the widget won't find 9.4)? What happens when you open the widget and try to use it? Have you enabled access for assistive devices in System Preferences?

 

It's probably best to have one of the support team screenshare with you to see these things, otherwise we are shooting suggestions in the dark. Email us your contact info and tome zone, and we'll get back to you.

Link to comment
Share on other sites

Sorry it took so long to get back. I did what Joel Brown said and it worked. I deleted my current copy and the plist. Then reloaded and it works fine. Thanks.

Link to comment
Share on other sites

  • 4 weeks later...

Pat:

 

There are so many variables here. What system are you on? Have you upgraded to Accordance 9.4.1 (it's possible that the widget won't find 9.4)? What happens when you open the widget and try to use it? Have you enabled access for assistive devices in System Preferences?

 

It's probably best to have one of the support team screenshare with you to see these things, otherwise we are shooting suggestions in the dark. Email us your contact info and tome zone, and we'll get back to you.

 

Hi, Helen

 

A support team may be what I need. [Either that, or a stress counsellor! ;>)]

 

I have been having trouble with the new widget, too, though the trouble is different from what the others are having here.

 

I can get the widget installed, but it doesn't register any of the Bible versions I have. I can click on the i in the bottom right to get it to turn around, check the Auto Search, Auto Insert boxes, but when I click on the double arrows for the drop down list of installed Bible versions, nothing happens. And nothing appears in the Bible version window.

 

When I insert a Bible reference on the front and hit Return, it tells me "Error receiving verse(s)." (Also, after deleting the reference, the scroll doesn't "rewind.")

 

I have upgraded to Accordance 9.4.1. I am still using Snow Leopard, but I have upgraded to the latest version of OS X, 10.6.8. I have also enabled access for assistive devices in System Preferences.

 

Before re-installing the Widget each time, I have deleted all the com.OakTree.Accordance files in my Preferences folder. (There used to be 3 of these. Now there's only the com.OakTree.Accordance.Path.txt file, if that means anything.) I have also deleted the widget-com.oaktree.widget.Accordance.plist file each time.

 

Given this info, can you suggest anything?

 

Thanks.

 

Norm

Link to comment
Share on other sites

Norm, what version of the widget are you running? What happens if you press Update on the back, does Accordance give you your translations? Are you sure when reinstalling the widget that you have totally removed all instances of the widget from your dashboard?

Link to comment
Share on other sites

Norm, what version of the widget are you running? What happens if you press Update on the back, does Accordance give you your translations? Are you sure when reinstalling the widget that you have totally removed all instances of the widget from your dashboard?

 

Joel, I'm running version 1.6.4 which I had downloaded separate from Accordance 9.4.1 (I'm aware that the widget included with Accordance 9.4.1 is still version 1.6.3.)

 

Pressing Update does not give me my translations. (When I said "versions" in my original post, I meant "translations.") No translations show up, front or back, before or after pressing Update.

 

As far as I can tell, there is no trace of the widget left before I reinstall version 1.6.4.

Link to comment
Share on other sites

Norm,

 

Here's something to help diagnose the problem.

Open up the application called Applescript Editor (You can find it in the folder Applications/Utilities/)

Create a new blank window if one didn't open automatically using Command-N or menu File/New

Paste the following code into the script window:

 

-- GetModuleListTest
set AppleScript's text item delimiters to ", "
try
tell application "Accordance" to set theResult to («event AccdVerL») as string
on error err
set theResult to err
end try
set AppleScript's text item delimiters to ""
set the clipboard to theResult
display dialog theResult

 

Click the "Run" button

It will show the result in a dialog box, and it will put that result on the clipboard.

Come back here and paste the resulting message in a new post here.

Edited by Joe Weaks
Link to comment
Share on other sites

Hi, Joe

 

Here's the result I got from running the script you gave me:

NRSVS, TNIV, NET, NAB, TEV, NJB, JPS, KJVS, NRSV2, RSV, REB, KJV, ASV, BBE, DRBY, KJVA, NLT-SE, WEB, WEBSTR, WEYMTH, YNG

 

By the way, ever since I first had trouble with the widget (back with Accordance 9.3) I've been using

Link to comment
Share on other sites

Norm,

 

That posting will help Joel see at what point the error is. That listing is the listing you should be seeing in your Module list in the Widget.

 

I'm glad you find the Services useful. The Services work great in Lion. I just last night updated them for the Accordance 9.4. I had to change two lines of code to account for a process name change.

 

Joe

Link to comment
Share on other sites

Norm,

 

That posting will help Joel see at what point the error is. That listing is the listing you should be seeing in your Module list in the Widget.

 

I'm glad you find the Services useful. The Services work great in Lion. I just last night updated them for the Accordance 9.4. I had to change two lines of code to account for a process name change.

 

Joe

 

Thanks, Joe. Yes, that was the list I was expecting to see when I clicked on the double arrows on the back of the widget and by clicking on the Update button.

 

Great to hear that making your services work with Lion is done and was that easy. Thanks again for being so generous in making them available to us. They're a real time saver.

Link to comment
Share on other sites

I'm still having problems with the widget pasting into Word. I am running OS 10.6.8 on a MacBook. I have Accordance 9.4.1 and Widget version 1.6.4. Accordance is installed in the standard install location and I have used the widget a lot over the years. This problem seems to have started since I upgraded to the new widget and Accordance 9.4.1. Every time I try to paste into Word a window pops up wanting me to locate Accordance. When I select Accordance it tries to find it then brings back the "Find Accordance Window" again. Other times it doesn't do anything but sit there. I have also enabled the Assistive Devices. I can fix the problem by deleting the pref. files and the widget and reinstalling the widget. For that session it works fine. Then it starts it all over again when I try and use it the next time Accordance and Word are started again. Any ideas?

Link to comment
Share on other sites

Just went through the whole process again. Deleted widget and pref. files. Reloaded. Worked great. Shut down Word and Accordance. Opened them both again. Still worked fine. Shut down computer. Opened both programs again and widget can't find Accordance.

Link to comment
Share on other sites

I believe that this bug is fixed in the next widget version (1.6.5), released with Accordance 9.4.2. These should be out very shortly.

Link to comment
Share on other sites

  • 2 weeks later...

I believe that this bug is fixed in the next widget version (1.6.5), released with Accordance 9.4.2. These should be out very shortly.

 

Joel I downloaded the new version 9.4.2 and the widget installed but I still have problems with the pasting in keynote & pages it works about 50% of the time and just stops working then starts again. I am not sure where to go to get this fixed. I even went through the read me process and made sure I did everything according to those instructions.

 

Thanks

Pat

Link to comment
Share on other sites

  • 2 years later...

I have been told that the widget does not work with Mavericks. This was from a customer. Since I don't want to upgrade to Mavericks, I have no way of testing this.

Link to comment
Share on other sites

Mavericks did eliminate one feature. You can't auto copy the current selection to use as the verse reference. (You can use a Service for this.)

Otherwise, the Widget works. Download is here: http://www.accordancebible.com/Accordance-Installers/#Widget

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...