Jump to content

Italics Won't Display in User Tool Edit Window


Lorinda H. M. Hoover
 Share

Recommended Posts

I'm been having this problem for some time; I think ever since I started using Accordance on my new MacBook pro running Accordance (which would be early April). While working in the User Tool Edit window, Italics never display. They display correctly in "regular" User Tool panes and tabs.

 

If I turn off smoothing, the italics appear, but the text is hard to read (like an old dot matrix printer). I do not have this problem on Accordance running on my iBook G4/10.4.11.

 

So it looks like it is a Snow Leopard specific problem? Or is it just my machine?

 

Lorinda

Link to comment
Share on other sites

It may be that you are missing the italic style in the Helvetica font on this computer. Check FontBook and make sure that you have the Oblique style active.

Link to comment
Share on other sites

It may be that you are missing the italic style in the Helvetica font on this computer. Check FontBook and make sure that you have the Oblique style active.

 

Thanks for the suggestion, Helen. I checked and all my Helvetica styles (including Oblique) are active.

 

Lorinda

Link to comment
Share on other sites

I still think that is the problem. Duplicate font? Corrupt? Maybe replace it with one from another system?

Link to comment
Share on other sites

I've had a problem with corrupted font files myself lately. I've found that completely replacing them with the font files in question from another Mac fixes the problem.

Link to comment
Share on other sites

According to FontBook, there are no duplicates or corruption. The copy of Helvetica on my iBook is much older. I tried replacing the newer Helvetica on the MacBook with the old one from the iBook, but it won't let met, even after I authenticate.

 

Lorinda

Link to comment
Share on other sites

I have since used Disk Utility (on my Install DVD) to repair my disk and repair permissions. I have also cleared all the Font Caches using Onyx. Still no Italics display in Accordance.

 

Interestingly enough, while Font Book says the entire Helvetica font family is o.k. when I validate Fonts. Helvetica Oblique does not appear in the NeoOffice font list. (In NeoOffice, every variation of a font a listed in the Font List, including Oblique, Bold, Bold Oblique, etc.) But despite this omission, Italics do display in Helvetica in NeoOffice, although in the Character Format window, I am warned that the style will be simulated. (edit: see my next post below)

 

I have no problems in Text Edit or Pages.

 

It would appear that the corruption only creates problems in certain programs, including Accordance.

 

Do you have any further suggestions for me?

 

Lorinda

Edited by Lorinda H. M. Hoover
Link to comment
Share on other sites

Update: After checking in with the NeoOffice support folks, I discovered that Helvetica Oblique is not missing in it's font list; it's just listed below all the Helvetica Neue variations. So that rules out my earlier theory. I'm back to it only being a problem in Accordance but nowhere else on my machine.

 

Lorinda

Link to comment
Share on other sites

I would appreciate further suggestions. This appears to be an Accordance specific issue, and I'm at a loss as to how else to try identifying or correcting a possible (but to my mind unlikely) font corruption.

 

Lorinda

Link to comment
Share on other sites

  • 1 month later...

I believe in this thread we determined that the italic style must be named "Italic" for Accordance to apply italics for a font. If the font uses oblique or any other variation, it won't work. The font must have a style named "Italic".

 

Helvetica uses "Oblique" so the italic style is not applied. But, if you change to Helvetica Neue, the italic is applied properly because Helvetica Neue has the style named "Italic". I have tested this with about 20 different fonts, and this was the case with all of them. "Italic" works, "Oblique" does not.

 

Hope that helps.

 

--

Brett

Link to comment
Share on other sites

Brett:

 

Thanks for the additional info. What puzzles me is that other people can apparently see italics in the User Tool Edit Window, but I can't.

 

It's not a problem in the "display" windows (when I pull up a User Tool to read it), as I have the font set to Fontin Sans Regular.

 

But I know of no way to set the font in the User Tool Edit window to Helvetica Neue. My only choices are Helvetica, Yehudit, Helena, and Rosetta.

 

Lorinda

Link to comment
Share on other sites

But I know of no way to set the font in the User Tool Edit window to Helvetica Neue. My only choices are Helvetica, Yehudit, Helena, and Rosetta.

 

Open the Accordance preferences (Accordance -> Preferences or command-,). Select User Notes Window from the left side content bar. The very bottom option in that window says: "Use default fonts in font menu". If you uncheck that box, you should be able to see all of your fonts from any window in Accordance.

 

--

Brett

Link to comment
Share on other sites

Open the Accordance preferences (Accordance -> Preferences or command-,). Select User Notes Window from the left side content bar. The very bottom option in that window says: "Use default fonts in font menu". If you uncheck that box, you should be able to see all of your fonts from any window in Accordance.

 

--

Brett

 

That works in User Notes but not in User Tools. At least not on my machine.

Link to comment
Share on other sites

Did you relaunch Accordance? Sometimes you have to quit and relaunch to see the font changes.

 

--

Brett

Link to comment
Share on other sites

  • 9 months later...

I'm still having trouble with this. Nothing suggested above has fixed it. I am finding it increasingly annoying. Is there any hope for a fix?

 

To reiterate, this is only an issue in the User Tools Edit window. But it makes keeping my formatting correct extremely difficult.

 

Lorinda

Link to comment
Share on other sites

I have never found a solution. My computer skill is somewhere between power user and developer and I have worked on it for many hours. I've tried everything suggested and lots of things not suggested. I've even done a complete system and Accordance re-install. It still won't do italics. I've given up on it.

Link to comment
Share on other sites

I think we need to change the default font to one that does have the italics style, and that everyone has. Ideas?

Link to comment
Share on other sites

There's a helpful list here.

 

Based on that list, I'd suggest one of the following:

 

Arial

Georgia

Helvetica Neue

Optima

Palatino

Times New Roman

 

Lorinda

Link to comment
Share on other sites

Geneva is a core system font (i.e. it is located in /System/Library/Fonts/). It is guaranteed to be on everyone's machine. It has been around since the beginning of the Mac OS so it is even on machines running Mac OS 6-9.

 

I just tested it and all of the styles work in the user notes window--italic, bold, and underline.

 

Although, I'm still very curious as to why Helvetica works on some people's machines and not others. :) After a clean install of Snow Leopard and a clean install of Accordance, Helvetica still wouldn't display italics in the user notes window. It's perplexing.

Edited by Brett K.
Link to comment
Share on other sites

At least one of the reasons it doesn't work is because the italic style is named "oblique" for Helvetica. I just tested it and I finally got Accordance to apply italics to Helvetica in a user note window.

 

I extracted the oblique font from the Helvetica dfont file. I opened it with FontForge and changed every occurrence of Oblique to Italic. Then I exported it as an open type font named Helvetica-Italic.otf. I installed it in /System/Library/Fonts/ (where Helvetica resides). And now italics work with Helvetica.

 

I can't imagine why Accordance won't recognize oblique on some machines but it will on others. Maybe those people have a Helvetica italic font hiding somewhere on their computer. :)

 

In any case, this is at least one part of the problem.

Link to comment
Share on other sites

I believe there is a bug in Accordance where it tries to use Helvetica CY Oblique to render the Italics for Helvetica, rather than Helvetica Oblique directly. Is it possible that you don't have the Helvetica CY font installed? We'll be fixing this bug shortly and sending it to you two for testing before 9.3.3, to confirm if this does solve the problem.

Link to comment
Share on other sites

No I do not have Helvetica CY installed. I assume it is included in the additional language fonts which can be installed with OS X. I did not install those fonts.

 

Thanks for looking into this.

 

--

Brett

Link to comment
Share on other sites

No I do not have Helvetica CY installed. I assume it is included in the additional language fonts which can be installed with OS X. I did not install those fonts.

 

Thanks for looking into this.

 

--

Brett

 

That is interesting, as it is listed on the wiki page as always being included. Anyway, expect an e-mail or message shortly with a potentially fixed version.

Link to comment
Share on other sites

According to this list, Helvetica CY is one of the optional fonts in Snow Leopard. I do not install the optional fonts when I install the OS as they are primarily for foreign languages and they take up a lot of space.

 

I look forward to testing out the fix.

 

Thanks

 

--

Brett

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...