Jump to content

Incorrect Search Results for BHS-T 2.1


bjnoonan
 Share

Recommended Posts

Accordance 13.2.1, Lenovo Y700, Windows 10

Biblia Hebraica Stuttgartensia (BHS-T) 2.1

 

With the most recent update of BHS-T from 2.0 to 2.1, I no longer get accurate search results. For example, if I search for the tag [VERB], it finds only one result: the infinitive construct בוֹא in Judg 3:3. As another example, if I search for the tag [NOUN], I receive the message "The selected grammatical tag cannot be found in the BHS-T text."

 

I have repeated this search numerous times, always with the same result. I have confirmed that I am searching correctly too: The search option is set to "Words," the tag is inputted correctly (both manually, typing in the tag, as well as using the Search > Enter Tag input option), etc. I don't have this problem searching with any of the other Hebrew databases (e.g., HMT-W4). I have tried doing the searches when I first open Accordance, after I've been using it for a while, etc., and it always fails to find the correct search results.

 

There are no apparent issues with the tagging because I can still put the cursor over any word and it lists it as a noun, verb, etc. as it should. So, the problem seems to be with how the search is interfacing with the tagging. 

 

Finally, it seems relatively certain that the problem is with the most recent update of BHS-T. I say this because, to try to fix the issue, I uninstalled Accordance and BHS-T and did a clean install. Searches once again worked in BHS-T until I checked for content updates, at which point BHS-T was updated to the latest version and searches no longer produced expected results. 

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Sorry about this. It should be fixed in 13.2.2 which is set to be released soon.

Link to comment
Share on other sites

Thanks for this update, Mark. The 13.2.2 update did come out recently, but after installing it I still have the same issue. Is there anything that we need to do besides installing 13.2.2 to fix this issue?

Link to comment
Share on other sites

I deleted BHS-T and found it again in Easy Install and that seemed to fix it - it's gone back to 1.8 which should work.

Link to comment
Share on other sites

Thanks @bjnoonan, I hadn't noticed this bug. I've updated to 13.2.2, but as you noted, the problem is still there.

 

However, I'm not sure how to follow @Douglas Fyfe's suggestion to delete and re-install the module. How do you delete a module? [Sorry if this is a basic question: I've been using Acc for just a few years after over 20 with BW, so I'm still figuring out some of the finer details.]

 

Thanks,

Matt

Link to comment
Share on other sites

1) Right-click on the BHS-T in your library and select "Remove Item." Then select "Move to Trash."
2) Select Easy Install (in the "Utilities" menu on a PC) to download the current release version of the BHS-T (version 1.8).
 

  • Like 1
Link to comment
Share on other sites

@Mark Allison

But should not also the App itself prevent now to update the texts until the bug is fixed? I see with 13.2.2 the 3 Hebrew texts to update. 

My understanding was, that Accordance prevent now if the text are newer than the app can handle. If this should be, then it doesn't work properly.

Link to comment
Share on other sites

@Mark Allison

Thanks! It worked. I realized that I was trying to remove it from the Recent list in the Library, but when I clicked on it in 'Texts', it worked. 'Remove Item' was grayed out for the Recent items.

Link to comment
Share on other sites

13 hours ago, Fabian said:

@Mark Allison

But should not also the App itself prevent now to update the texts until the bug is fixed? I see with 13.2.2 the 3 Hebrew texts to update. 

My understanding was, that Accordance prevent now if the text are newer than the app can handle. If this should be, then it doesn't work properly.

 

Yes, the Hebrew Texts won't update themselves until new updates are ready. But if you've already updated the Texts, the only way to revert back to the earlier version is to delete them and reinstall. 

Link to comment
Share on other sites

@Mark Allison

but why I see the item in the update section? This should not be. This is confusing. 

Edited by Fabian
Link to comment
Share on other sites

55 minutes ago, Fabian said:

@Mark Allison

but why I see the item in the update section? This should not be. This is confusing. 

 

Thanks for the heads-up. That should be fixed now.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...