I don’t know if this is related, but I can’t open these updated modules on my iPad. It says these texts require a newer version of Accordance even though I’m running the latest version from App Store. The MT-AFD and old BHS-W4 will open, but not the HMT-W4, BHS-T, or ETCBC.