Jump to content

Original language question/request or bug


Iconoclaste
 Share

Recommended Posts

I think it's a bug, so I'll post here, but I may be missing something as well. 

 

What are the settings in the “Unicode Display” section of the preferences supposed to change? They do not change the font for Hebrew texts in Accordance. If that is not what these settings are for, I have another question: How do I change the font for a Hebrew or Greek text? The font settings in the “Text Display” settings only changes the font for English (or other modern Latin-alphabet languages) texts. 

Link to comment
Share on other sites

The Unicode display settings relate to when you export text out of Accordance. For instance, you copy and paste some Hebrew from Accordance to a word processor. You are choosing what Unicode font in the word processor you want to use for your exported Hebrew text. 

 

The fonts within Accordance cannot be changed. They're finely tuned to appear correctly in the program. Not all external fonts do this as well.

  • Like 1
Link to comment
Share on other sites

Thanks, Ruby. In that case, why is there the option “Use these fonts for Unicode export” and why aren't they greyed out when that is not selected? And why is it called “Unicode Display settings”? Is this the same choice of Hebrew and Greek export font that is available from the “Export” section of the preferences? Does the same feature/setting appear twice? I'm just confused.

Link to comment
Share on other sites

For specific Hebrew, Greek, and other advanced rendering, its more more accurate and faster to render non-unicode.  For this reason (and some others), many of our primary texts are non-Unicode, designed to work with our specific fonts, and thus you can't change the font of them.  We also have many places in the program where Unicode content does render (User Notes, Instant Details, some tools, etc.).  In these places, the original languages often look better using a dedicated font than an all-purpose font, so this preference pane is where you can define that.  So, regardless of your choice of "use these fonts for Unicode export", these fonts will be used when rendering those fonts in unicode.

 

If you do select the 'Use these fonts' checkbox, then it will also use these fonts for any unicode export of these languages, whether or not they came from a unicode text.

 

On the Export preference pane, I'm not sure which choice you are seeing there.  There are three semi-related preferences on that pane.  A "general" font export, that will be used for all content ("Use default font:"), though this would be overridden for original languages if you set the "Use these fonts for Unicode export" preference.  There are also the two popup menus for "Export characters as:", but this is when going to other, legacy, non-Unicode fonts.  So, it is dimmed if you are exporting as unicode.

 

I hope this helps clarify!  It is quite a number of options to help all of the varied use cases our users regularly deal with.

  • Like 2
Link to comment
Share on other sites

SInce it's too late to edit my previous post, I now revise my previous words since the internet allows me to: “Thanks, not Ruby.” Also, perhaps, to be consistent, I should have said: “Thanks, Administrator.”

  • Like 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...