Jump to content

Accordance Font


bdollahite
 Share

Recommended Posts

Environment:  On a Macintosh using Accordance 13.0.5  (But my issue has been true across various MacOS versions and Accordance versions)

 

Issue:  When I copy any text's or tool's content that is displayed in the Accordance font into MS Word, what I copy is displayed almost like it was in Accordance.  The difference is the spacing between lines.  (The issue is best seen in the attached PDF).

 

Detail info:  When I paste in MS Word using the Paste and Match Formatting menu item, the line space issue is resolved  — at least for English only texts.

 

[NOTE:   This paste option is not always available in other apps — e.g. when pasting the same-copied text into MS PowerPoint.  This may be a PowerPoint issue and the slide predefine formats may also be contributing to my issue.]

 

When copying English and Hebrew text — like from my K&D Library module — the normal paste appears again at 1.5, and the Hebrew is preserved.  However, pasting into MS WORD using Paste and Match Formatting — the line space issue is resolved, as I was in Times New Roman, but the Hebrew is not displayed well.  Two issues: The Hebrew points are not under the letters, and while the right to left spelling is preserved, the Hebrew words are reverse (i.e., if the following quoted English were Hebrew words "three two one" — copying and pasting comes out as "one two three" but the characters in each Hebrew word are correctly shown right to left.)  Selecting the Hebrew text and changing it to the Accordance font fixes the pointing issue, but the word order now needs to be addressed and the line spacing issues returned.  Reordering the words, while straight forward, is a time consuming process, and once done then the line space issue needs tp be fixed by using MS Word's "Paragraph" formatting menu and forcing the lines in that paragraph to be a fixed point size, which I guess at to make the results look like the rest of my paper.

 

Attempts to resolve:  I have worked with several people in Accordance support as well as Webinar instructors — all that ultimately have encouraged me to post this issue here as a feature request (as they likewise saw no easy or known fix to my issue).

 

I have also tried various preference changes — some at webinar instructors’ suggestions,  as well as my own testing.  To date, none of those changes have resolved my issue.

 

Desired feature:  The ability, within Accordance, to set the line spacing used on copy/paste and export, or at least set the line spacing default to be single line space (which seem more logical to me than defaulting to space and a half.  Space and a half is just my guess as what is pasted line spacing is — it appears to be 1.5 lines spaces — see attached PDF).  I appreciate some of the issue in that mix language characters may need for space.  I see this in my K&D module — where lines with Hebrew take up more line space than lines containing nothing but English text.  That said 14 point etc. should be 14-point text when displayed.  If the Hebrew is to small then I see two options — increase font size displayed in the tool's content window, or an option to do what it does today — English at one height, Hebrew/Greek at another.  Having the ability to set these preferences and have them carry through to the export to whatever app I pasted into, would be an appreciated new feature.

 

Link to comment
Share on other sites

I do not see an attached PDF, but I'll attempt to reply regardless.

 

I cannot reproduce what you experience - when I paste into MS Word, it always comes in as "1.0" line spacing.  If I paste and match style, I also still get the correct characters, in the correct order.  I think that there is simply a set up issue on your computer.

 

First, what version of MS Word are you running?

 

Second, have you updated to the latest version of the Accordance font (v1.2 as of this post)?  The 1.1 update to the font reduced the line spacing significantly.

 

There are a few preference options that you may want to adjust on your computer:

 

1) In 'Export' try enabling 'Export all characters with Unicode format'.  This will ensure that the characters are correct, regardless of the destination font.

2) When you Paste and Match Style, you tell MS Word to render the Hebrew using whatever font you were using at the time.  If that font doesn't have all of the characters, such as the Hebrew cantillation marks, they would appear as the dotted circles.  If you don't want to use the Accordance font, then you may want to automatically strip the characters your desired font can't handle.

3) If you are sure you want to always use the Accordance font, you can select that under 'Use default font:'.

4) You can also, under the Unicode Display preference, choose a specific font for each language.  This way you could specify the Accordance font for Hebrew, but the rendering font for all other text.

  • Like 1
Link to comment
Share on other sites

Hi Joel, 

 

1)  I am using MS Word 2011, and MS Word 2016 (as part of an Office 365 Subscription).  Issue also appear in Apple's mail.app mail reader, Apple's TextEdit, Apple's Pages,  – so I don't think its a MS Word issue. 

2) I have Export all character with Unicode format set in my Accordance preferences.

3)  I have seen the dotted circles to which you refer — they were seen on the PDF that for whatever reason didn't seem to post to this forum, albeit I attached it. I am not sure why or what is going on there, and I don't see how to post it again as part of this reply.  I am fine with the Accordance font as long as it is single-spaced.  I have it installed.

4)  I have selected used Accordance as my default font - it just the line spacing issue with which I have to deal.

5)  I had already done as you suggested in the Unicode Display preference, but I don's see how to set a font for English texts - as that is where I see the space and a half issue.  

 

I trust you saw that I also stated I see the same issue inside Accordance modules like K&D. It seems display font sizes are ignored, or Accordance is doing "1.5" (more than 1.0) spacing on Hebrew fonts in the module display.

 

I am not sure how to tell what version of Accordance font I have installed. 

 

Is it possible to schedule a time slot where I could do a screen share (I have a Cisco Webex account and would be glad to schedule a meeting for us at your convenience, and that way you can see my screen, we can talk live (face to face), and if necessary I can let you share your screen (if you so desired and need to do so).  And the good news is that the issue is very easy fro me to reproduce.  As I stated, this has been an ongoing issue since Accordance 10 (if I recall correctly) and I would be a great productivity enhancer to me if it can be resolved.  

 

I am willing to post back here what we find, so others may benefit, but I think continuing this discussion offline (if you are willing) would be best.  If you agree — please email me at bert@dollahite.org.  If you disagree, you may email me or post reply here.  

 

Whatever the next steps —thank you for your suggestions and willingness to help me.

 

-Bert

Link to comment
Share on other sites

Joel — I figure out how to post the PDF, but as it is a 5MB PDF, and this Forum will not accept files greater than 2MBs — that is why its not posting.  sigh ---- I will see if I can compress it somehow.

Link to comment
Share on other sites

Joel — I hope you can read a MS Word .docx format as it much smaller — and can be posted, and I have done so here.  I still think the best approach is to meet offline.  Your opinion?

Link to comment
Share on other sites

My bad — I thought it had uploaded, but I seat didn't.  When I went back to upload, I was told I dont have permission to upload a docx type file.  PDF is now 2.4MB, which is still to big to upload.  sigh... 

Link to comment
Share on other sites

I guess you have to zip it anyway. 

 

And there are some PDF shrinker available.

Link to comment
Share on other sites

Joel — issue resolved (or close enough).  

 

Details:  Mark Alison explained how to have Accordance install whatever the latest version of its fonts are, and I did such.  With the latest version of Accordance font installed, the line spacing is greatly reduced (say form 1.5 to 1.05 spacing).  I can live with the extra line space given all of the benefits the accordance fonts brings with it use.  

 

Process (to ensure you have the latest set of Accordance fonts):  On a Mac hold down the option key (I think is control on a PC, but no sure) when starting Accordance and select the check box to install latest font set.  

         FYI:  You should also restart (or quit) all applications that are running that use fonts.  This is recommended for if an Accordance font was updated, the app will most likely still be using the older font (the one that Accordance replaced/updated), and the new fonts install may not display correctly as the app's font menu was most likely built as part of the app's start up process — and thus the latest Accordance font(s) would not be known by that app.

 

Open Question:  How does one determine the version number of the Accordance font?  As I now know how to ensure I have the latest fonts installed, this is more of an academic and item of interest question.  Joel, if you have time to answer, doing so would be appreciated.

Link to comment
Share on other sites

I'm glad to hear you got the issue resolved!

 

To view version information for a font, open the Font Book application, select the font, and choose View -> Show Font Info.  You'll see the version number listed among all of the other font information on the right.

  • Like 2
Link to comment
Share on other sites

I started my Windows Accordance and held the Control key and I saw no messages or dialog boxes. I don't see an option to check for fonts in Preferences. I found this via Google: https://www.accordancebible.com/Accordance-Font/. You can get there from the Accordance home page > Support > Other Downloads > Accordance Font. 

 

(Windows) From the Start button you can type fonts and go into the Font settings (which is in System settings), and click/tap on the Accordance font, and it tells you the Version # & Build date. (Well look at that, I don't have the latest version. ...Wait now, maybe I do. The Accordance.ttf file in 'C:\Program Files (x86)\Oaktree\Accordance\Resources\Fonts' has a date stamp of 2020-0608 and file version is 1.2. Perhaps Font settings is not the best place to verify version? Hmmm.)

 

Cheers.

Link to comment
Share on other sites

I started my Windows Accordance and held the Control key and I saw no messages or dialog boxes. 

 

Hold down the "Alt" key on Windows.

  • Like 1
Link to comment
Share on other sites

Thank you, Mark! That brings up the Accordance Safe Mode dialog box (screenshot attached). 

 

http://accordancefiles2.com/helpfiles/Win13/Default.htm#topics/10_ref/db/db_safe_mode.htm?Highlight=safe%20mode

 

Help article says "Clean up installed fonts" is an item in the "Clean up" section. However, I don't see that option (Win 10 + Acc 13.1.1)

post-35562-0-20707100-1592255263_thumb.png

Edited by Drewster
Link to comment
Share on other sites

Thank you, Mark! That brings up the Accordance Safe Mode dialog box (screenshot attached). 

 

http://accordancefiles2.com/helpfiles/Win13/Default.htm#topics/10_ref/db/db_safe_mode.htm?Highlight=safe%20mode

 

Help article says "Clean up installed fonts" is an item in the "Clean up" section. However, I don't see that option (Win 10 + Acc 13.1.1)

This is only Mac related.

  • Like 1
Link to comment
Share on other sites

Sorry. In Windows, go to the Utilities menu and select "Update Accordance Fonts."

  • Like 1
Link to comment
Share on other sites

Sorry. In Windows, go to the Utilities menu and select "Update Accordance Fonts."

 

Ugh, hiding in plain sight right there in front of me. Thank you! Is this necessary to do as a separate step if I keep my program at the latest version?

  • Like 1
Link to comment
Share on other sites

Ugh, hiding in plain sight right there in front of me. Thank you! Is this necessary to do as a separate step if I keep my program at the latest version?

 

Only if you're having font issues. Otherwise you can disregard it.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...