Jump to content

Syncing Mac library after syncing dividers crashes Accordance iOS

Ken Hall

Recommended Posts

Recently I attempted to sync Mac library dividers to iOS, and although they synced successfully, every time afterward, the iOS app crashed upon attempting the next sync. This happened on both my iPad and iPhone. A window came up with an obscure error message, "I/O Error #%@ in the file '%@'." (Screenshot attached from iPhone for error message.) 


At first I did not know the reason for the error, but after searching the Accordance iOS help pages, I found the following statement under ‘crash while syncing’:


Blank or garbled rows in the Library window of Accordance for iOS may cause a crash when syncing. You can remove them like any other row in the Library View. Either swipe across the row (hit the Delete button to confirm the deletion), or enter Edit mode using the "Edit" button in the top bar of the Library View, tap on the delete switch for the row in question, and then confirm the delete. Remember to tap the "Done" button in the top bar of the Library View when you are done editing.


I then looked through my texts and tools in the library, and wherever I had synced divider lines from the Mac, there were blank rows in the iOS library view. So, following the instructions, I deleted all those rows. I did this on both my iPhone and iPad. From then on, everything synced perfectly again with the Mac and the issue has not recurred.


Hence I've concluded that it is a no-no to sync divider spaces from the Mac to the iOS library. With this in mind, I'd like to ask for a bug fix so that the user cannot inadvertently get himself into a situation where he/she crashes the iOS app. Either:


(1) Not allow blank divider rows/spaces to be synced from Mac to iOS in the first place, OR


(2) If the sync encounters any blank rows, give a warning message to the effect that “blank rows found in library, please delete before syncing” (or similar wording), OR  (It took me awhile to figure out the cause of the crash; I did not immediately realize the connection between the crash and the divider rows.)


(3) Both # 1 and #2 above.


From the help pages, it is a known condition that it's possible to have 'blank modules' that will crash Accordance for iOS when syncing. Can a fix be put in place such that it's not possible to have blank rows in the Library View to begin with, thus avoiding the crashes?
Thanks for any help.


Link to comment
Share on other sites

Ken, library dividers, on iOS, do show as blank cells, but these are accounted for in the syncing logic. There are times when you might have a library corruption that would produce additional blank library cells, which I believe is what the help documentation was referring to. I'll look into this to see I perhaps missed something, and while I do so, could you let me know if there were any other issues with your library the might have caused the blank cells?

Link to comment
Share on other sites

 library dividers, on iOS, do show as blank cells

Can we have a -------- in the blank, so they isn't so empty anymore :rolleyes:





  • Like 1
Link to comment
Share on other sites

Thank you for looking into this, Graham. As far as I know, there were not any other issues with the library that might have precipitated this problem. On both the iPhone and iPad, the sync attempt crashed, but when I removed the blank rows, both devices suddenly synced properly. Thus it seemed that the issued centered around the presence of blank rows. Nothing else was going on that I’m aware of.


Before I figured out what the problem was (or what I concluded the problem was from the help pages), I actually reinstalled Accordance on the iPhone, based on the suggestion from Tech Support. I would have also reinstalled it on the iPad, but because the sync crash still persisted on the iPhone, that’s when I scoured the help pages to discover what seemed to be the answer. So when I deleted the blank rows in the iPhone library and the syncing worked, I tried the same on the iPad (without reinstalling it) and the syncing worked. I concluded that the problem was the blank rows and nothing else.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...