Jump to content

Troubleshooting basic Hebrew construct searches


mbl
 Share

Recommended Posts

Hi,

 
I'm new to the HMT Syntax module and have been working through the Brief User's Guide.  However, other the first sample search (sec 5.1 null predicate clause), I have not been able to reproduce the results in the guide either by building the construct searches myself or using the downloadable workspaces (from https://www.accordancebible.com/Documentation/).  I have tried this with several searches--for example, the image below (Fig 1) is from sec 5.3 .  The only change I made to the original workspace was to limit the range to Genesis, which would still allow me to verify the first several results shown in the user's guide.
 
post-35815-0-76011000-1571171229_thumb.png
 
To narrow down the problem, I tried a couple smaller searches to "build up" to the construct search of Sec 5.2 (null predicate without participial complement).  First, I had no problem finding a null predicate within a predicate phrase.  As shown in Fig 2, there were two hits in Gen 1:2, as expected.
 
post-35815-0-28285200-1571171244_thumb.png
 
I also searched within a predicated phrase for a complement phrase without a participial complement.  The results for Gen 1:2 are also what I would have expected (Fig 3)
 
post-35815-0-74893400-1571171262_thumb.png
 
If I tighten up the construct so the depth = 0, the results narrowed, as expected (Fig 4).
 
post-35815-0-04162000-1571171275_thumb.png
 
If I am understanding the constructs correctly, then by combining these two searches  to look for predicate phrases containing both a null predicate and non-participial complement, I should expect the results to include [עַל־פְּנֵ֣י תְה֑וֹם - ] in Gen 1:2, as shown in the figure on p.51 of the guide.  However, I do not get any results in the range (Gen), as shown below (Fig 5).
 
post-35815-0-58953200-1571171288_thumb.png
 
The same thing happens when I run 2-NullCopulaNonParticipialComp.accord directly (again, changing the range to Gen) as in Fig 6.
 
post-35815-0-28029300-1571171342_thumb.png
 
 
I have also tried to reproduce several other construct searches from this forum, with similar lack of success.  (And of course, I've tried the obvious restarting, confirming all modules are up to date, etc.)
 
Any suggestions would be most appreciated.
 
Thanks!
 
Link to comment
Share on other sites

Ok, I spent over an hour working on the searches. There is definitely something "broken". They searches are *really* slow and there are no hits. This must have happened during some update of Accordance. I'll ask that it's looked into for the coming 13 release.

  • Like 2
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...