Jump to content

Type Hebrew in Windows 10


Martin Z
 Share

Recommended Posts

Hello,

 

I use Keyman with Ezra SIL keyboard.

Wonder if anyone can help?

 

Typing real consonants and vowels are fine, but when I use ◌ to represent a consonant, I have problem.

 

For example, I want to type Qal Qatal paradigm, I need to type 

post-32138-0-48083600-1475272079_thumb.png

This is like mission impossible for me.

 

Thanks a lot!

Martin

Link to comment
Share on other sites

Hi Martin,

 

I chose to accept this impossible mission.

 

I copied and pasted the dotted circle in your post, and its Unicode value is U+25cc, not the same value as the dotted circle you see when you type a vowel with the Ezra SIL keyboard. That character is U+0000, Null. But, I can’t get either dotted circle to combine with a vowel. I vaguely recall there used to be a way to combine characters in Word. You could look that up on the Internet.

 

But, a simpler way would be to make a table, type each vowel in a separate cell with the dotted circle, and erase the border lines when you were done.

 

Regards,

 

Michel

Link to comment
Share on other sites

Hello Michel,

 

Thank you for your reply.

It works fine in Numbers on Mac.

The interesting thing is that I need to type two dotted circles before I type vowel(s).

The text direction is different depending on if there is a real consonant (preformative/sufformative). But at least I can work around.

If I export to Excel, it messes up.

I'm just wondering why I can't do it on windows.

 

I don't know how the text books do it. Some textbooks have a box instead of the dotted circle.

 

Blessings,

Martin

Link to comment
Share on other sites

Hi Martin,

 

  This just works for me in LibreOffice with the SIL keyboard in Win 10. I use the Cardo font which can display it. I am not using Keyman, just the keyboard from the SIL. If I type a vowel without a consonant I get stuff like :

 

  ַ ָ ְ

 

  in fact just as I typed those above. To get multiple side by side like that you have to hit space between each one. If you don't they end up combined which of course might be desired.

 

Thx

D

Link to comment
Share on other sites

Thanks, Daniel.

But I need to have either a dotted circle or a box to represent a Hebrew consonant. Most consonants do not have shewa when they are in the end of the word and do not have a vowel.

 

Blessings,
Martin
Link to comment
Share on other sites

Wow - that did not render when I hit post - it was there when I typed it. Let me get you a screenshot from LO and see if what I am describing is actually what you meant.

 

post-32023-0-75653800-1475339418_thumb.jpg

 

post-32023-0-51395000-1475339430_thumb.jpg

 

post-32023-0-48776800-1475339425_thumb.jpg

 

thx

D

Edited by דָנִיאֶל
Link to comment
Share on other sites

Hello Daniel,

 

This indeed looks much better.

Have you tried to have several dotted circles in a row, such as the Qal Qatal strong verb paradigm, lets say, the 3ms form?

Depending on which font I use (Times New Roman, Ezra SIL), it is rendered differently. But somehow I was not able to type the 3ms (with three dotted circles representing the three root consonants). The 3rd consonant (without vowel) always stays in the beginning of the word rather than in the end of the word.

 

Thanks,

Martin

Link to comment
Share on other sites

Ok couple of things : the vowels I pasted in above in my paste look fine on my PC in Firefox. They do not render the circles on Mac Firefox. I don't know why not but could easily be a font issue.

 

I took your paradigm above and tried to type the first three lines. Two things I cannot reproduce. Here is what I could :

 

post-32023-0-83294100-1475382127_thumb.jpg

 

Now what I could not are these :

 

post-32023-0-32526000-1475382197.jpg

 

In the image above I do not know what this is. I cannot find a single glyph that matches it. It looks like it could even be a qamats sheva but that's not consistent with other shevas in you example so that seems unlikely unless that combination produces a badly rendered glyph. I can do a qamats sheva though.

 

post-32023-0-61456800-1475382207.jpg

 

This one I cannot find. I don't know what the < above the character is produced by in the first place, much less whether I can combine it with anything else. My keyboard viewer seems to show characters that might be intended to be a left and right < > but I cannot get them to render as such. They end up as א ע which is perhaps a mapping fault in either keyboard or font, not sure.

 

Thx

D

Link to comment
Share on other sites

Hello Daniel,

 

The vertical line to the left of Qamets is metheg. It is used when Qamets is followed by a vocal shewa. Otherwise, the "T" shape vowel may be Qamets Hatuf, and the shewa will be silent. It is not consistent marked in the BHS, but the textbooks usually consistently use the metheg. For Ezra SIL keyboard, it is "Option/Alt + 1."

 

The < above a consonant is a sign for accented syllable when it is not the ultima. It is "Option/Alt + Shift + \."

 

Blessings,
Martin
Link to comment
Share on other sites

Hey Martin,

 

  Thanx for the explanation. I can produce the qamats with the accent indicator over it with a dotted circle in Ezra SIL. In Accordance I cannot get the dotted circle. In Cardo I cannot combine the two marks but I get a dotted circle for each. For the metheg I cannot produce that from the Alt-Shift + 1. Rather I get a large dot over the circle - right-alt-shift+1. Left alt-shift 1 does nothing. Oh ok I found it - metheg is right-alt-1 (no shift) and it will combine with a qamats in Ezra SIL font. It won't combine on a dotted circle in Cardo, but will with a consonant. With Accordance it will render without a consonant but as before there is no dotted circle and the combination is rendered so that the metheg overlaps the vertical stroke of the qamats - thus not really visible though the qamats looks a little bolder.

 

  So yes I can do this in Ezra SIL it seems in LibreOffice on Win 10.

 

Thx

D

Link to comment
Share on other sites

Hello Daniel,

 

Thanks a lot!

Looks like LibreOffice does the best job.

 

Blessings,
Martin
Link to comment
Share on other sites

Hi Martin,

 

Daniel is right, it works with spaces in LO, but it takes some fiddling. If you type rtl, as I was doing, the dotted circle doesn’t show up until you type a second vowel. Starting a rtl line with a space fixes that. Also, if you type ltr, the first use of ַ    lines up left of center under the circle. The second use is perfect.

 

So, I tried this in Word (Online, since I use Linux), and it also works with a bit of fiddling.

 

post-32543-0-28330000-1475509175_thumb.png

 

Publishers/authors often use InDesign to combine characters, and/or tables to line them up perfectly.

 

Regards,

 

Michel

 

Edited: substituted ַ   for the the dotted circle with פַּ֣תַח that didn’t render correctly

Edited by Michel Gilbert
Link to comment
Share on other sites

Hello Michel,

 

Thanks a lot for your detailed explanation.

Yes. I was able to type that with an extra space!

 

Blessings,
Martin
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...