Jump to content

v.2.0: Links to Bible verses don't work in user notes


Recommended Posts

I pasted some text in the user notes on my iPad and was pleasantly surprised that Accordance made them into links. But tapping on those links didn't bring up popup window. Tapping on the link creates grey background for that link and that's all. 

Link to post
Share on other sites
Mike Garrity

Guntis,

 

Can you post a screenshot with the problematic User Note link that you are trying to get Instant Details by tapping? Also, what is the first Text Module in your Library?

 

I noticed a bug when the scripture reference was not in the top Text and wanted to see if that was the same issue for you.

 

 

Thanks for the feedback,

Mike

Link to post
Share on other sites

First text is NRSVS. Here are screenshots:

post-634-0-88358500-1426880623_thumb.jpg

post-634-0-45205000-1426880640_thumb.jpg

Link to post
Share on other sites
Mike Garrity

Unfortunately, I am not able to reproduce the problem:

 

post-406-0-16944500-1426883234_thumb.png

 

I added a Psa 22:21 note, typed the last line of your user note, tapped done. The scripture links appear to be auto linked just like yours.

 

Am I missing something?

 

Do the other links fail?

Link to post
Share on other sites

All links in user notes fail. The same behavior - link background turns grey and no popup window.

Link to post
Share on other sites

And today links in user notes suddenly started to work. Nothing's done on my part. Go figure...

Link to post
Share on other sites

And today links in user notes suddenly started to work. Nothing's done on my part. Go figure...

None of the links in my User Notes work either.
Link to post
Share on other sites
Mike Garrity

RANorem

 

Can you post screenshots (similar to Guntis) of your Text category and bad User Note scripture link?

 

Mike

Link to post
Share on other sites

RANorem

 

Can you post screenshots (similar to Guntis) of your Text category and bad User Note scripture link?

 

Mike

I will have to do some research first since I have never posted a screenshot from my phone. I will try to get back with that soon. Thanks!

Link to post
Share on other sites

RANorem

 

Can you post screenshots (similar to Guntis) of your Text category and bad User Note scripture link?

 

Mike

 

Mike, I have made a screenshot but I have not been able to find a way to post it as a thumbnail. Any help with that?  Thanks 

 

My problem looks just like that which Guntis had before his started working.

 

Roger

Edited by RANorem
Link to post
Share on other sites
Fabian

If you "Reply" there is a "More Reply Option" button right down next to "Post". And then you'll be able.

 

Greetings

 

Fabian

Link to post
Share on other sites

Thanks, Fabian!  Appreciate your help.

post-29964-0-02585900-1428070433_thumb.jpg

Link to post
Share on other sites

I apologize for the repeat, but I think this image is more clear. Thanks

 

Roger

 

post-29964-0-48824400-1428076288_thumb.png

Edited by RANorem
Link to post
Share on other sites
rcdeacon

My links DO NOT work either! IOS a 2.0

Link to post
Share on other sites
Mike Garrity

I was able to reproduce the problem with Roger’s Notes (the Deut 4.2 link worked on the desktop but did not in iOS):

 

post-406-0-23237200-1428099172_thumb.png

 

We are looking into the problem,

Mike

Edited by Mike Garrity
Link to post
Share on other sites
rcdeacon

Additionally, I synced via Dropbox and then checked the SAME links on the my MBP and unfortunately the links DID NOT work there either! I used IOS 2.0 and my desktop is 10.10.3 public beta.

Link to post
Share on other sites
rcdeacon

Please disregard my last. They DO work on desktop but DO NOT work on my mini. Sorry

Link to post
Share on other sites
  • 3 weeks later...

Mike, I believe that I accidentally stumbled unto a solution to my User Notes problem. I simply re-ordered the list of texts and now the syncing seems to be working fine and the links are intact. Let me know if this works for you. Thanks.

Link to post
Share on other sites
  • 2 weeks later...
Guntis

Links in my user notes don't work again...

Link to post
Share on other sites
Scott Knapp

We have some reproducible cases that we're trying to track down the underlying issue and fix it. If the notes are in a parallel pane try changing to a different text module in the primary pane and see if they start working again.

Link to post
Share on other sites
Tony Lawrence

I posted this in the wrong section, but I think this may be of help so I will copy and paste what I posted there:

 

I finally identified an issue that I had been having with pop-ups with Accordance for the iOS. Sometimes the Scripture links in my User Notes would pop-up correctly and sometimes they would not. As late as today I sync the notes between my Mac desktop where the instant details would show the links correctly and then on my iPad some would and others would not. 

 
I looked carefully at the link and noticed that the dash in between Luke 1:16–17 was actually an en dash instead of a normal dash. The Mac version of Accordance recognizes is perfectly, the iOS version did not. When I edited my User Notes with a normal dash, sync again, then presto, it worked perfectly. 
 
Now, here's the issue, I copied the Scripture reference out of a module. So my guess is that several of the modules were the result of scanning and the en dash was recognized in the place of a normal dash. Perhaps the easiest way to fix this issue is for the iOS version to recognize en dashes along with ordinary ones.
Link to post
Share on other sites
Scott Knapp

This has been fixed already for v2.0.1 which is currently undergoing internal testing.

 

Thanks for the feedback.

  • Like 1
Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...