Jump to content

BUG 10.3.2 - Verse Search for Matthew Returns Genesis


Matt Fredenburg
 Share

Recommended Posts

Not sure how this happened. I had just opened up the workspace, 'Various Bible Versions' after Accordance had crashed. The last time the workspace had been saved, the search entry had contained a list of ~8 verses. I selected the verses with the mouse, pressed 'Delete,' typed 'matthew' into the search entry box and pressed return. This is what my workspace looked like immediately after:

post-30573-0-31823600-1384927460_thumb.png

 

It is also worth noting, that after I had done a couple of word searches, that if I then switched back to do a verse search with 'matthew,' that the correct results were displayed. So, I then saved the workspace at that point, but when I opened it again, it showed 'matthew' in the search entry box, but once again, the content of all the panes was of Genesis 1:1.

 

Further worth noting: I don't actually have to perform a word search, I just have to click on the dropdown, select 'word', then click on the dropdown again, select 'verse', and then execute the search, and it correctly displays Matthew 1:1.

 

Also, if I have Accordance set to start up with my most recent session, and that most recent session is 'Various Bible Versions,' then when I reopen Accordance it displays the search entry box with 'matthew,' and it properly shows search results starting with Matthew 1:1. If I then open the 'Various Bible Versions' workspace (which had been saved with the same state), it incorrectly displays Genesis 1:1 for the verse search of 'matthew.'

 

And perhaps finally, I validated that a similarly constructed workspace works properly in Accordance for Mac 10.3.2.

 

Matt

Edited by Matt Fredenburg
Link to comment
Share on other sites

I just opened the same workspace today and entered '1 John' into the search entry box and it still displayed Genesis 1:1. So, it appears that it's not related to what is typed into the search entry area, as every verse search I've tried fails. Only if I first select a 'word' search, then switch back to a 'verse' search does the search succeed. But, even though the search for 1 John succeeded, the next verse search I did (e.g. for Romans) failed and took me back to Genesis 1:1. If I then select a 'word' search, then switch back to a 'verse' search, the search for Romans succeeds, but then the cycle begins anew. Is Accordance attempting to tell me that I need to go back to the beginning in some spiritual way?! <_<

 

Matt

Edited by Matt Fredenburg
Link to comment
Share on other sites

This one keeps getting stranger. I just exited Accordance, and it started out as follows:

post-30573-0-54593900-1384987400_thumb.png

 

I then clicked on the Verses/Words search dropdown, clicked on Words, then clicked on the dropdown again and clicked on Verses.

I entered 1 John 3 into the search entry box and pressed Enter.

The search executed and operated as one would expect:

post-30573-0-87611100-1384987407_thumb.png

 

I then magnified the top zone so that my workspace now appeared as follows (notice the Tab is entitled 'ESVS'):

post-30573-0-26300000-1384987414_thumb.png

 

I then entered 'Matthew' into the search entry box and my workspace became this (notice the Tab is now entitled 'NTL-SE'):

post-30573-0-24769300-1384987422_thumb.png

 

The zone that is magnified has swapped with the zone that was unmagnified.

 

Matt

 

Link to comment
Share on other sites

This feels like the issues with unexpected workspace windows coming to the fore in some conditions which still happens on some error conditions. Curious.

 

Thx

D

Link to comment
Share on other sites

  • 2 weeks later...

This bug still exists in 10.3.3. I just executed a verse search for 1 John 3, and the results are as follows:

post-30573-0-67682800-1386217986_thumb.png

 

If I change from a verse to a word search (without actually performing a search) and then back to a verse search and execute the search, I get the results one would expect.

 

Matt

Edited by Matt Fredenburg
Link to comment
Share on other sites

  • 2 months later...
  • 2 months later...

This bug still exists in 10.4.1...

 

Matt

Link to comment
Share on other sites

I see what's going on now, Matt. Its an interesting mix of Auto Context, [CONTENTS], and Tieing. We'll look into fixing it, but in the meantime let me explain *why* its happening so you can understand some of the workarounds.

 

Since you have Auto Context enabled (Preferences -> Search Tabs), a verse search for 1 John 3 displays your results with All Context, so the entire text is shown, scrolled to 1 John 3.

 

Your tab that is linked with your main search text is using a [CONTENTS] command, which takes each of the verses found in your source tab and shows them in your NLT-SE tab. This happens after each search, of course, as it needs to know what verses your source tab is dispalying.

 

Finally, you have them tied so that they scroll in sync. However, when you run a search in a document, it also updates the tieing after the search is run.

 

So, what happening is your source tab has all text, scrolled to 1John 3. After the search, the [CONTENTS] command brings in all of those verses, so that tab is now simply display all bible text. Then, it tries to update its tied documents, and since it just pulled in new verses, its scrolled to Gen 1:1, so it scrolls your other tabs to Gen 1:1 as well.

 

Technically each aspect is working perfectly, but I agree its quite an illogical outcome after putting them together. Here are some workarounds in the meantime:

 

1) Use [LINK] rather than [CONTENTS]. This brings in the search argument rather than the found verses, so your destination NLT basically does the same search as your ESVS and ends up at the same place, 1John 3.

2) Have the different panes of your NLT tab be on your ESVS tab instead of part of a separate tab. Remember, a tab can have as many panes as you want, pending screen space, and you can have your panes occupy a second row. They'll automatically appear there if you run out of room on the top row, or you can move them around with drag and drop or the gear menu. This is certainly your best option if your only desire was to show your verses in those extra translations as well.

3) Turn off auto-context. If all you wanted to see was 1 John 3, it will give you just those verses, and you can adjust the context yourself with the Context Slider. Then, since Gen 1:1 isn't being displayed, it will also scroll properly for you.

 

I hope this helps!

Link to comment
Share on other sites

  • 2 months later...

Hi Joel, I finally got a chance to try out suggestion (1) above. It worked great!

 

Thanks so much,

 

Matt

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...